+ Post New Thread
Results 1 to 8 of 8
Hardware Thread, Promethean Problem in Technical; We have a problem with 1 of our Promethean boards. It was all working fine, then 1 day just decided ...
  1. #1
    dezt's Avatar
    Join Date
    Dec 2005
    Location
    Lancs
    Posts
    1,030
    Thank Post
    157
    Thanked 60 Times in 48 Posts
    Rep Power
    30

    Promethean Problem

    We have a problem with 1 of our Promethean boards. It was all working fine, then 1 day just decided to ignore the pen, everything looks fine, the board is recognised on the PC and appears to be working fine, the power light is on the board and everything looks ok, but when you move the pen on the board nothing happens. I've tried 3 different pens and still nothing. Anyone come across this before???

    Any ideas would really help.

    Thanks

  2. #2
    iatkinson's Avatar
    Join Date
    Jun 2007
    Location
    Blackburn
    Posts
    135
    Thank Post
    5
    Thanked 6 Times in 5 Posts
    Rep Power
    16

    Re: Promethean Problem

    We've had issues with Windows updates clashing with both the drivers and the firmware. Might be worth re-installing newest driver and possibly firmware to see if this helped. For all intents and purposes it told us the boards were working but no reaction until after updated.

  3. #3

    plexer's Avatar
    Join Date
    Dec 2005
    Location
    Norfolk
    Posts
    13,569
    Thank Post
    721
    Thanked 1,682 Times in 1,497 Posts
    Rep Power
    432

    Re: Promethean Problem

    Is the pc definately displaying the board as being a "promethean activboard" in device manager and not just a Human Interface Device?

    If it's the later change the driver back to the correct one, using the latest signed driver should help too.

    Ben

  4. #4

    Join Date
    May 2006
    Location
    West Bromwich
    Posts
    2,192
    Thank Post
    300
    Thanked 215 Times in 185 Posts
    Rep Power
    57

    Re: Promethean Problem

    Have promethean signed their drivers now then?

    Do they install like they should without having to specify the driver after the installation?

    I ask as i haven't supported a promethean board for over a year.

    To be honest i don't really miss them either. I found them to be a little troublesome. Software is good though.

  5. #5

    plexer's Avatar
    Join Date
    Dec 2005
    Location
    Norfolk
    Posts
    13,569
    Thank Post
    721
    Thanked 1,682 Times in 1,497 Posts
    Rep Power
    432

    Re: Promethean Problem

    Yes they now have a signed driver and I've just pushed it to clients or installed it manually and then they plug the board in and it works.

    Ben

  6. #6

    Join Date
    May 2006
    Location
    West Bromwich
    Posts
    2,192
    Thank Post
    300
    Thanked 215 Times in 185 Posts
    Rep Power
    57

    Re: Promethean Problem

    Getting better then :-) ?

  7. #7
    PEO
    PEO is offline
    PEO's Avatar
    Join Date
    Oct 2007
    Posts
    2,096
    Thank Post
    457
    Thanked 152 Times in 96 Posts
    Rep Power
    72

    Re: Promethean Problem

    Quote Originally Posted by plexer
    Yes they now have a signed driver and I've just pushed it to clients or installed it manually and then they plug the board in and it works.

    Ben
    is this the driver of the promethean site or the one of the microsoft site?

  8. #8
    sahmeepee's Avatar
    Join Date
    Oct 2005
    Location
    Greater Manchester
    Posts
    795
    Thank Post
    20
    Thanked 70 Times in 42 Posts
    Rep Power
    34

    Re: Promethean Problem

    We've had quite a few instances where the driver tries to install itself again whilst a normal user is logged on, which it can't do because it needs admin rights. They then get repeatedly bombarded with the install screen (green progress bar on black background) until we come and fix it by logging on as an admin then logging them back on. Days later it might happen again on the same PC.

    It's strange because it behaves itself on most PCs and they're from an image. My current theory is that it has something to do with them disconnecting the USB cable although I'm not sure of the exact circumstances to replicate it..

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 11
    Last Post: 13th May 2009, 12:08 PM
  2. Promethean Watermark
    By popularITguy in forum Educational Software
    Replies: 6
    Last Post: 30th October 2007, 04:51 PM
  3. New Promethean Stuff
    By StuartC in forum Hardware
    Replies: 17
    Last Post: 29th June 2007, 10:03 AM
  4. Promethean weird problem
    By sbutterworthtj in forum Windows
    Replies: 6
    Last Post: 19th June 2007, 09:37 PM
  5. Promethean KB
    By drjturner in forum How do you do....it?
    Replies: 24
    Last Post: 20th April 2007, 08:09 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •