+ Post New Thread
Results 1 to 9 of 9
Hardware Thread, Sahara/delta AV-2107 projector service menu in Technical; Hi I have a faulty sahara project in school. It has really bad ghosting have spoken to sahara and the ...
  1. #1

    Join Date
    Nov 2007
    Posts
    18
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Sahara/delta AV-2107 projector service menu

    Hi

    I have a faulty sahara project in school. It has really bad ghosting have spoken to sahara and the tell me it is due to the lcd timing and needs to be adjusted using the service menu, but the won't tell how to get into the service menu to do it. They want me to send it back and pay for repair because it is out of warrenty. If anyone has any idea how to get into the service manual please could you let me know.

    Thanks

    Carl

  2. #2

    SimpleSi's Avatar
    Join Date
    Jun 2005
    Location
    Lancashire
    Posts
    5,822
    Thank Post
    1,476
    Thanked 593 Times in 445 Posts
    Rep Power
    168

    Re: Sahara/delta AV-2107 projector service menu

    Don't know but....

    If its that old then I'd replace it.

    The bulbs are very expensive and its not really cost-effective to replace them or maintain the projector.

    New project will cost about £400 and will be much brighter and have a higher resolution and the bulbs will be much cheaper (£150 instead of £300). (manucfactures sometimes give free bulb warranties

    The cost can go up if you need to move the old mount or replace the plate but all my heads have agreed that this is the way to go if an old expensive to maintain projector/bulb goes wrong.

    regards

    Simon

  3. #3
    welshgirljo's Avatar
    Join Date
    Nov 2008
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Can anyone help with this? I have same problem?

    Or how do I do the factory reset? Does anyone have a manual for this projector that I could have a copy of too?

  4. #4
    welshgirljo's Avatar
    Join Date
    Nov 2008
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    In case anyone needs it. To get into the service menu, press down, up, left, right when you have no inputs.

  5. #5

    Join Date
    Mar 2010
    Location
    leeds
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    well i fixed my ghost image on sahara av-2107 from within the service menu, have had the problem over a year before found this, many thanks

  6. #6
    Sirbendy's Avatar
    Join Date
    Nov 2005
    Posts
    2,298
    Thank Post
    8
    Thanked 203 Times in 154 Posts
    Rep Power
    111
    I had a lot of issues with these Saharas..dodgy ballasts were the usual.

    Solved the issue with ours..by dropping them in the bin. Ha. Hateful units. Now got Lan-managed NECs throughout.

  7. #7
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,226
    Thank Post
    455
    Thanked 178 Times in 175 Posts
    Blog Entries
    3
    Rep Power
    65
    I'm feeling really thick at the moment.

    Whenever I try to bring the service menu up, it just cycles through the options for keystone and source, doesn't bring up a service menu. No other connections apart from power plugged in.

    Anyone point me to what I'm doing wrong?

    Edit: Never mind, was being thick. Forgot to use my regular steady rhythm.
    Last edited by Cache; 4th May 2010 at 11:27 PM.

  8. #8

    Join Date
    Oct 2011
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    meaby someone now hot to get to service mode in sahara av-600 pls? i am looking for this for over a month and cant fin it...

  9. #9

    Join Date
    Jan 2013
    Location
    Glasgow
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi
    I have a sahara s2000 and it has developed bad ghosting. I could not find a Service manual on the internet to figure out how to fix it. I tried your suggestion disconnected the inputs and then press down, up, left, right when you have no inputs, one at a time in that sequence and nothing happened. Can you advise in any way or send me a link to a service manual the user manual is no use for maintenance issues. Thank you.

SHARE:
+ Post New Thread

Similar Threads

  1. Sahara projector problem
    By SteveT in forum Hardware
    Replies: 8
    Last Post: 11th November 2008, 10:13 PM
  2. Create menu & sub-menu with Edugeek Joomla
    By FN-GM in forum EduGeek Joomla 1.0 Package
    Replies: 24
    Last Post: 8th December 2007, 11:48 PM
  3. Different Sahara projector problem
    By The_Traveller in forum Hardware
    Replies: 5
    Last Post: 13th March 2007, 01:09 PM
  4. I've never been a fan of Sahara...
    By Ric_ in forum Recommended Suppliers
    Replies: 14
    Last Post: 9th May 2006, 10:03 AM
  5. Replies: 8
    Last Post: 5th November 2005, 07:13 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •