+ Post New Thread
Results 1 to 4 of 4
Hardware Thread, IBM ThinkPad R50e Laptops - Not working in Technical; Hello We have about 15 or so IBM R50e laptops that appear to be experiencing the same problem. Basically when ...
  1. #1
    firefox_2006's Avatar
    Join Date
    Oct 2006
    Location
    Midlands
    Posts
    200
    Thank Post
    13
    Thanked 19 Times in 13 Posts
    Rep Power
    20

    IBM ThinkPad R50e Laptops - Not working

    Hello

    We have about 15 or so IBM R50e laptops that appear to be experiencing the same problem. Basically when you try and turn them on, the power LED and fan comes on, but there is nothing on screen (Just black). We have tried swapping various components in and out with no luck so far.

    Anyone got a clue what could be wrong with them? I have a feeling that it could be something on the motherboard, however it strikes me as a little odd when I have 15+ of them all doing the same thing.

    firefox_2006

  2. #2


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339

    Re: IBM ThinkPad R50e Laptops - Not working

    Try and power them without the battery plugged in.
    Also is bios automatic update turned on?

  3. #3
    firefox_2006's Avatar
    Join Date
    Oct 2006
    Location
    Midlands
    Posts
    200
    Thank Post
    13
    Thanked 19 Times in 13 Posts
    Rep Power
    20

    Re: IBM ThinkPad R50e Laptops - Not working

    Try and power them without the battery plugged in.
    Also is bios automatic update turned on?
    Tried that, does not work either. Don't know about the "bios automatic update" because I cant get it to boot up on screen.

    Would be nice if I could get these laptops working again......please help!

    firefox.

  4. #4

    Join Date
    Feb 2013
    Location
    dakar
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    hi, i have an ibm R50e which have the same problem as yours (fan spinning, leds on, nothing but a black screen). Have you found a solution? please help me if so. Thank you in advance

SHARE:
+ Post New Thread

Similar Threads

  1. SATA drives in laptops and RIS not working
    By tosca925 in forum Windows
    Replies: 2
    Last Post: 27th November 2007, 10:38 AM
  2. ibm/lenovo supplier for thinkpad's
    By torledo in forum Hardware
    Replies: 3
    Last Post: 4th October 2007, 10:30 AM
  3. IBM ThinkPad R50e Laptops
    By firefox_2006 in forum Hardware
    Replies: 0
    Last Post: 20th April 2007, 08:22 AM
  4. IBM ThinkPad G40 - Locked BIOS/Hard Drive
    By Zoom7000 in forum Hardware
    Replies: 5
    Last Post: 3rd April 2007, 01:14 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •