+ Post New Thread
Results 1 to 8 of 8
Hardware Thread, pcl-xe40 in Technical; At our school we have several projectors of the following brand: Sanyo PLC-xe40. It gives no ligth. After starting the ...
  1. #1

    Join Date
    Sep 2012
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    pcl-xe40

    At our school we have several projectors of the following brand: Sanyo PLC-xe40.
    It gives no ligth. After starting the green led is burning for a moment. After several seconds the red ligth is blinking.
    Normaly the bulb is broken. After replacing the bulb, we are having the same problem. Can anyone help me??

  2. #2

    VeryPC's Avatar
    Join Date
    Aug 2012
    Location
    Sheffield
    Posts
    2,198
    Thank Post
    1,304
    Thanked 1,234 Times in 668 Posts
    Rep Power
    363
    There's a manual here that refers to blink red light = overheat . It then refers to an air filter cleaning process.

    Sanyo PLC XE40 | Owners Manual - Page 53

    Hope this helps

    Andy

  3. #3

    Join Date
    Sep 2012
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I've followed the instructions in the manual. No results. I don't want to sen it to a servicestation, because it is an old projector.
    Maybe the projector must be reset after cleaning. But how?

  4. #4

    Millgate's Avatar
    Join Date
    May 2011
    Location
    Sheffield
    Posts
    1,511
    Thank Post
    483
    Thanked 400 Times in 256 Posts
    Rep Power
    158
    If you can't fix it yourself and you need someone to come out and take a look, let me know and i'll send you a quote.

    Thanks

  5. #5

    VeryPC's Avatar
    Join Date
    Aug 2012
    Location
    Sheffield
    Posts
    2,198
    Thank Post
    1,304
    Thanked 1,234 Times in 668 Posts
    Rep Power
    363
    Sorry I can't be much use here , other than recite the manual.

    Andy

  6. #6
    Boredguy's Avatar
    Join Date
    Jun 2011
    Location
    Swindon
    Posts
    685
    Thank Post
    4
    Thanked 150 Times in 139 Posts
    Rep Power
    54
    Have you reset the thermal trip?

    Disconnect from Mains.
    Take the lid off the projector (can be done with Projector still mounted if your careful and disconnect the IR lead).
    Looking at it with the bulb and connectors nearest you, there is a small hole near the brown power plug from the side fans (just up and right of the connector)
    Using a straightened paperclip, poke the hole to depress the switch.
    Put lid back on.

    Oh, here is the post with the pictures Cleaning the Sanyo PLC-XE40 projector
    Last edited by Boredguy; 2nd October 2012 at 03:18 PM.

  7. #7
    Iain's Avatar
    Join Date
    Oct 2006
    Location
    Warwickshire
    Posts
    195
    Thank Post
    28
    Thanked 98 Times in 56 Posts
    Rep Power
    36
    A guide for cleaning this projector and resetting the thermal trip was posted in this thread a while ago:

    Cleaning the Sanyo PLC-XE40 projector

  8. #8

    Join Date
    Sep 2012
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks a lot
    it was very helpfull



SHARE:
+ Post New Thread

Similar Threads

  1. Cleaning the Sanyo PLC-XE40 projector
    By Gromit in forum Hardware
    Replies: 77
    Last Post: 3rd May 2013, 10:05 PM
  2. Sanyo PLC-XE40 will not startup
    By Skinny in forum Hardware
    Replies: 5
    Last Post: 8th October 2010, 03:33 PM
  3. Quote for replacement lamp for sanyo PLC-XE40
    By bladedanny in forum Our Advertisers
    Replies: 5
    Last Post: 5th November 2009, 10:01 AM
  4. whats the differance between EMF and PCL 5/6
    By timbo343 in forum Windows
    Replies: 11
    Last Post: 10th January 2007, 10:50 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •