+ Post New Thread
Results 1 to 7 of 7
Green Computing Thread, Papercut Secondary server in Technical; Sorry if this isn't the right forum, Couldn't decide which one to put it in. We recently installed Papercut v12 ...
  1. #1
    BJC
    BJC is offline

    Join Date
    Dec 2009
    Location
    West Mids
    Posts
    39
    Thank Post
    2
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Papercut Secondary server

    Sorry if this isn't the right forum, Couldn't decide which one to put it in.

    We recently installed Papercut v12 on our member server which works perfectly but we've now installed it as a secondary print server on all computers with a locally attached printer. It installs fine and the log reports that it is connected to the primary server but after about 5 minutes it looses connection and never gets it back. Therefore never reports any printing.

    This is on an RM CC4 network, Server 2003 member server with XP workstations.

    However if we install the secondary print server on a Windows 7 workstation it works fine.

    Anyone got any idea what could be causing it? I wasn't planning to roll out windows 7 until Summer and could do with getting this sorted before the new financial year.


    Thanks in advance for any help.

    Ben

  2. #2
    Big_Ted's Avatar
    Join Date
    Apr 2011
    Location
    Clevedon
    Posts
    143
    Thank Post
    1
    Thanked 20 Times in 20 Posts
    Rep Power
    11
    Hi Ben,

    PaperCut seems to work fine with RM CC3/CC4 but i personally have noticed an issue like yours at a school before.
    They had installed the secondary server service on a XP box, the printers from the XP machine would show up in the main Admin UI but it would not log any print jobs.

    Now i have no idea what is in CC3/CC4 (never used it) so i asked the IT staff at this site if they could turn off any firewalls so we could troubleshoot this. With the firewalls of the problem remained, i then looked into AV software as some of those sometimes sneaky in their own firewalls (trend for example) so we disabled that but the problem remained. I then managed to gain remote access to the XP machine and looked in the "services" and noticed a long list of RM services running. One of these services was called like "network services.." i really cant remember but what it seemed to be doing was blocking any unusual traffic in and out of the machines. PaperCut does a lot of stuff over 9191 so as soon as we disabled this service everything worked.
    sorry i cant remember the name of the service but perhaps have a look and see if anything jumps out at you. I expect you can tell the service/program to stop worrying about 9191

  3. Thanks to Big_Ted from:

    BJC (1st February 2012)

  4. #3

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,342
    Thank Post
    405
    Thanked 652 Times in 595 Posts
    Rep Power
    188
    Quote Originally Posted by Big_Ted View Post
    Hi Ben,

    PaperCut seems to work fine with RM CC3/CC4 but i personally have noticed an issue like yours at a school before.
    They had installed the secondary server service on a XP box, the printers from the XP machine would show up in the main Admin UI but it would not log any print jobs.

    Now i have no idea what is in CC3/CC4 (never used it) so i asked the IT staff at this site if they could turn off any firewalls so we could troubleshoot this. With the firewalls of the problem remained, i then looked into AV software as some of those sometimes sneaky in their own firewalls (trend for example) so we disabled that but the problem remained. I then managed to gain remote access to the XP machine and looked in the "services" and noticed a long list of RM services running. One of these services was called like "network services.." i really cant remember but what it seemed to be doing was blocking any unusual traffic in and out of the machines. PaperCut does a lot of stuff over 9191 so as soon as we disabled this service everything worked.
    sorry i cant remember the name of the service but perhaps have a look and see if anything jumps out at you. I expect you can tell the service/program to stop worrying about 9191
    That'd probably be RM Network Monitor Service then.

    There's an update, DWN1781986, which fixes certain applications which are affected by this service. Might be worth speaking to RM about the issue you're facing and see whether there is a way to exclude the port? Rather than disable the service altogether.

  5. Thanks to Edu-IT from:

    BJC (1st February 2012)

  6. #4
    BJC
    BJC is offline

    Join Date
    Dec 2009
    Location
    West Mids
    Posts
    39
    Thank Post
    2
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Thanks Guys, it is the RM Network Monitor Service. I disabled it and it worked straight away. The service seems to be running from C:\Program Files\Research Machines\Auditor\Network Monitor.

    We never use Auditor as it never seemed to work properley so i uninstalled it from a workstation but the service remained as it's a default system package which i don't think you can remove.

    Does anyone know if this is definitely only related to auditor or will disabling the service cause other problems? I might completely uninstall auditor and see if it removes the service from system packages.

  7. #5

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,342
    Thank Post
    405
    Thanked 652 Times in 595 Posts
    Rep Power
    188
    Quote Originally Posted by BJC View Post
    Thanks Guys, it is the RM Network Monitor Service. I disabled it and it worked straight away. The service seems to be running from C:\Program Files\Research Machines\Auditor\Network Monitor.

    We never use Auditor as it never seemed to work properley so i uninstalled it from a workstation but the service remained as it's a default system package which i don't think you can remove.

    Does anyone know if this is definitely only related to auditor or will disabling the service cause other problems? I might completely uninstall auditor and see if it removes the service from system packages.
    This isn't installed with Auditor, from what I can see. We don't run Auditor yet this service is present.

    I'd say raise a call with RM if you have a valid support agreement as this is a fix that is needed IMO. The service shouldn't interfere with ports.

  8. #6
    BJC
    BJC is offline

    Join Date
    Dec 2009
    Location
    West Mids
    Posts
    39
    Thank Post
    2
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I don't have a direct support contract with RM so i've raised it with our county support who can then raise it with RM on my behalf. I also can't access DWN1781986 to see if that works as i don't have sufficient rights.

    The reason it works on Windows 7 must be because that service doesn't exist on our Windows 7 workstations.

  9. #7
    BJC
    BJC is offline

    Join Date
    Dec 2009
    Location
    West Mids
    Posts
    39
    Thank Post
    2
    Thanked 1 Time in 1 Post
    Rep Power
    0
    All Sorted.

    There's an RM update (CC4UPD093) which installs a new version of the RM Network Monitor service. Once this is installed on the workstations papercut works fine.

    The update is only available upon request, it's not with the others to download.


    Ben



SHARE:
+ Post New Thread

Similar Threads

  1. sophos secondary server address
    By IanT in forum Windows
    Replies: 6
    Last Post: 9th February 2009, 01:06 PM
  2. Secondary DHCP server
    By timbo343 in forum Virtual Learning Platforms
    Replies: 4
    Last Post: 12th October 2007, 01:45 PM
  3. Server Recommendation Please
    By altecsole in forum Hardware
    Replies: 29
    Last Post: 21st October 2005, 09:15 AM
  4. Event Log Every 5 Mins in Windows 2k Server
    By mrtechsystems in forum Windows
    Replies: 11
    Last Post: 26th June 2005, 10:50 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •