+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 33
General Chat Thread, Car Problem ? Maybe ? in General; Engine light flicking on or staying on?...
  1. #16

    Miscbrah's Avatar
    Join Date
    Dec 2011
    Posts
    885
    Thank Post
    244
    Thanked 251 Times in 151 Posts
    Rep Power
    114
    Engine light flicking on or staying on?

  2. #17

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,708
    Thank Post
    3,244
    Thanked 1,048 Times in 970 Posts
    Rep Power
    364
    Twin Turbo : View Profile: twin--turbo - EduGeek.net

    @twin-turbo

  3. #18
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,421
    Thank Post
    508
    Thanked 282 Times in 258 Posts
    Rep Power
    81
    Engine isnt running poorly per se... Company car makes the same noise so I think it's just air intake.

  4. #19
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,421
    Thank Post
    508
    Thanked 282 Times in 258 Posts
    Rep Power
    81
    Quote Originally Posted by Miscbrah View Post
    Engine light flicking on or staying on?
    Nope no engine lights at all..

    Something a bit weird did happen the other day. Filled up, and halfway home the speedo dropped to 0 for about 2 seconds then went back up to the speed I was doing.

  5. #20

    Join Date
    Jul 2013
    Location
    Solihull
    Posts
    127
    Thank Post
    13
    Thanked 23 Times in 18 Posts
    Rep Power
    7
    Quote Originally Posted by cpjitservices View Post
    Engine isnt running poorly per se... Company car makes the same noise so I think it's just air intake.
    Yeah I wouldn't worry much about it. As you say most likely just induction noise.

    You're clearly paying attention to the characteristics of your car so you will soon know when something is actually wrong.

  6. #21
    Joanne's Avatar
    Join Date
    Nov 2007
    Location
    Lancashire
    Posts
    1,504
    Thank Post
    116
    Thanked 112 Times in 104 Posts
    Blog Entries
    17
    Rep Power
    74
    Our Focus 1.6 diesel does the hissing thing, if yours is a diesel too it might be a turbo issue. Ours has done 154000 miles, so ready for replacing so we still run it as is. How old is your car? Our focus is a 55 reg.

    We had a corsa that used to lose power to the speedometers... think it was knackered!! Scary when it happens though!

  7. #22
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,421
    Thank Post
    508
    Thanked 282 Times in 258 Posts
    Rep Power
    81
    Quote Originally Posted by Joanne View Post
    Our Focus 1.6 diesel does the hissing thing, if yours is a diesel too it might be a turbo issue. Ours has done 154000 miles, so ready for replacing so we still run it as is. How old is your car? Our focus is a 55 reg.

    We had a corsa that used to lose power to the speedometers... think it was knackered!! Scary when it happens though!
    Mines a 1.6 Zetec SE... well I used to work on cars alot so I know a bit. I didnt actually loose nay power at all when the speedo dropped...

  8. #23

    Join Date
    Jul 2013
    Location
    Solihull
    Posts
    127
    Thank Post
    13
    Thanked 23 Times in 18 Posts
    Rep Power
    7
    Quote Originally Posted by cpjitservices View Post
    Mines a 1.6 Zetec SE... well I used to work on cars alot so I know a bit. I didnt actually loose nay power at all when the speedo dropped...
    Petrol then so no need to worry about turbo-issues!

  9. #24
    Joanne's Avatar
    Join Date
    Nov 2007
    Location
    Lancashire
    Posts
    1,504
    Thank Post
    116
    Thanked 112 Times in 104 Posts
    Blog Entries
    17
    Rep Power
    74
    no it's just really odd! When our car did it, all the needles died, then when it came back on all the lights lit up and the needles went back to where they should have been.

    Your 2 issues are probably unrelated.

    If it still drives and it passes its MOT.... IT'LL BE REIGHT!!!

  10. Thanks to Joanne from:

    cpjitservices (7th July 2014)

  11. #25
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,421
    Thank Post
    508
    Thanked 282 Times in 258 Posts
    Rep Power
    81
    Quote Originally Posted by Joanne View Post
    no it's just really odd! When our car did it, all the needles died, then when it came back on all the lights lit up and the needles went back to where they should have been.

    Your 2 issues are probably unrelated.

    If it still drives and it passes its MOT.... IT'LL BE REIGHT!!!
    Aye too right, MOT is due October... It's going in for a service and an all round check before it gets booked in... HOPEFULLY it wont fail. There's no rot or rust so I do hold a bit of hope lol

  12. #26
    arwen's Avatar
    Join Date
    Jan 2010
    Location
    Dundee
    Posts
    259
    Thank Post
    4
    Thanked 44 Times in 35 Posts
    Rep Power
    46
    What kind of journeys are you doing in it? Is it mostly short (less than 10miles) or around town driving all the time? It could just be gunk clogging your injectors. Buy a bottle of Injector Cleaner (Redex is the one I use, about 4 a bottle) and chuck that in the tank when you next fill up. Also, try not to run the tank to the bottom, fill up the tank when the light comes on to stop the gunk at the bottom of the tank getting pulled through the engine.
    Reving the car is also a way to clean it, or taking it for a long run (bit excessive, but I drove mine to Leeds last time it was doing this, it stopped juddering after 100 miles or so)

    My car suffers this a lot now, since I reduced my daily commute form 38miles each way, to 5miles each way. Sometimes the engine light flashes on, other times is doesn't. The Service will show up anything wrong with the air intake (hissing) but if there is no lights on the dash is probably isn't serious.

  13. Thanks to arwen from:

    cpjitservices (7th July 2014)

  14. #27
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,421
    Thank Post
    508
    Thanked 282 Times in 258 Posts
    Rep Power
    81
    Thanks @arwen

    I do usually use it for the 2-3 mile journey to work everyday... However I've done over 400 mile in it since I got it a month ago.. 200 miles as we went up North to visit family.. 60 Mile trip yesterday, Been to Bird etc so it's done some mileage.

    When I bought the car it was running on fumes, Just as I pulled into the filling station it started coughing. So got there just in time. Since I've owned it I've lot let it get below a quarter of a tank... And never would. I will try banging some redex through it see if that clears out any muck in the injectors.

  15. #28

    Join Date
    Feb 2013
    Posts
    134
    Thank Post
    2
    Thanked 15 Times in 11 Posts
    Rep Power
    41
    Someone has already said this I think - hiss could be exhaust blowing or air intake leak.. does it do this hiss when you're stood with the hood up or just while under load while driving..

  16. #29
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,421
    Thank Post
    508
    Thanked 282 Times in 258 Posts
    Rep Power
    81
    If I pop the hood and pull the accelerator it hisses just for a like a milli-second as the revs climb. I think its actually supposed to do it from reading on forums.. it's taking a breath lol

  17. #30
    newpersn's Avatar
    Join Date
    Nov 2010
    Location
    Gloucestershire
    Posts
    1,186
    Thank Post
    272
    Thanked 110 Times in 83 Posts
    Rep Power
    76
    All 3 of my fords did the same.

    1.3 efi engine
    1.6 zetec
    1.25 zetec.

    I always found it better to be in a higher gear than 5th all the time

SHARE:
+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Car problems
    By tmcd35 in forum General Chat
    Replies: 35
    Last Post: 26th February 2013, 03:47 PM
  2. Replies: 3
    Last Post: 28th August 2011, 10:51 PM
  3. Car problems
    By cromertech in forum General Chat
    Replies: 5
    Last Post: 23rd February 2011, 09:07 AM
  4. An annoying car problem...
    By amyr in forum General Chat
    Replies: 38
    Last Post: 25th June 2009, 07:22 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •