+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 22
Enterprise Software Thread, Live@Edu & Exchange in Technical; Hello all, I'm finally getting to grips with Live@Edu. I've set up all users by importing a CSV which was ...
  1. #1

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,265
    Thank Post
    242
    Thanked 1,575 Times in 1,254 Posts
    Rep Power
    341

    Arrow Live@Edu & Exchange

    Hello all,

    I'm finally getting to grips with Live@Edu. I've set up all users by importing a CSV which was fairly straight forward.

    There are two problems I have come across however -

    Users are prompted to specify their Time Zone and by default, the US Dictionary is used. Both of these can be resolved by using PowerShell. Unfortunately however Microsoft (it appears) seem to presume that us Live@Edu admins have an Exchange 2010 disc lying around for me to install the Exchange Snap-in.

    Is there no where at all I can download this? It seems crazy that I'd need to buy an Exchange 2010 license just to use the advanced PowerShell tools.

    Alternatively, if there is another method to resolving my two issues, please let me know

  2. #2

    Join Date
    Jan 2006
    Location
    Surburbia
    Posts
    2,178
    Thank Post
    74
    Thanked 307 Times in 243 Posts
    Rep Power
    115
    You don't need Exchange.
    If you're running XP there's a KB to install WinRM which includes powershell.
    If you're running Win7 you have powershell.
    You start powershell and use connection commands that are in this MS guide
    That automagically imports the Exchange cmdlets module when you connect.
    Last edited by PiqueABoo; 25th March 2012 at 10:48 PM.

  3. Thanks to PiqueABoo from:

    Michael (26th March 2012)

  4. #3


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    9,370
    Thank Post
    241
    Thanked 2,813 Times in 2,076 Posts
    Rep Power
    812
    Not sure what you have been reading, but you definitely don't need an existing Exchange server to administer Live@edu. That's what PowerShell Remoting is for e.g.

    Code:
    $LiveCred = Get-Credential
    $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://ps.outlook.com/powershell/ -Credential $LiveCred -Authentication Basic -AllowRedirection
    Import-PSSession $Session
    
    # Set all users in the tenant to British English and GMT Standard Time
    Get-Mailbox –Resultsize unlimited | Set-MailboxRegionalConfiguration –Language en-GB –TimeZone "GMT Standard Time"
    
    Remove-PSSession $Session
    Also, don't forget to set your execution policy if you haven't already done so.

    Code:
    Set-ExecutionPolicy RemoteSigned
    Last edited by Arthur; 25th March 2012 at 11:37 PM.

  5. Thanks to Arthur from:

    Michael (26th March 2012)

  6. #4

    Join Date
    May 2011
    Location
    Jus North of London, close but not too close
    Posts
    851
    Thank Post
    188
    Thanked 70 Times in 65 Posts
    Rep Power
    50
    I know that on Windows XP you had to use 'Powershell 2 with WinRM'. Haven't tried with Win7 as left old employment before we fully Implememted Win7.

    I couldn't use powershell behind the Countys poxy (or shouldn't that be Proxy) filtering system, so I had to either do all the Powershell work from home or use a USB dongle :-( .

  7. #5

    Join Date
    Jan 2006
    Location
    Surburbia
    Posts
    2,178
    Thank Post
    74
    Thanked 307 Times in 243 Posts
    Rep Power
    115
    You have to set the WinHTTP proxy to use powershell through a proxy (xp:proxycfg -p proxy.example.net, win7:netsh winhttp set proxy proxy.example.net)

  8. #6

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,265
    Thank Post
    242
    Thanked 1,575 Times in 1,254 Posts
    Rep Power
    341
    Thanks for the replies guys and maybe I wasn't 100% clear.

    I'm running Windows 7, and this does include PowerShell 2.0 and WinRM as standard.

    I open up PowerShell, I can authenticate OK, but then I get lots of errors (red text). I'll try again this evening what Arthur's kindly quoted as firewall rules (by the BGFL) are preventing me connecting successfully.

  9. #7
    jamesbmarshall's Avatar
    Join Date
    Feb 2010
    Location
    Reading, UK
    Posts
    550
    Thank Post
    27
    Thanked 239 Times in 166 Posts
    Rep Power
    88
    The script to set dictionary language is:

    set-mailboxspellingconfiguration -Identity <someone> -dictionaryLanguage EnglishUnitedKingdom

  10. #8

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,265
    Thank Post
    242
    Thanked 1,575 Times in 1,254 Posts
    Rep Power
    341
    What's the command to do this for all users please?

  11. #9
    jamesbmarshall's Avatar
    Join Date
    Feb 2010
    Location
    Reading, UK
    Posts
    550
    Thank Post
    27
    Thanked 239 Times in 166 Posts
    Rep Power
    88
    Quote Originally Posted by Michael View Post
    What's the command to do this for all users please?
    The great thing about PowerShell is that it is quite easy to pick up, and for the most part is quite logical; common sense!

    You can modify the code from earlier in the thread:

    Quote Originally Posted by Arthur View Post
    # Set all users in the tenant to British English and GMT Standard Time
    Get-Mailbox –Resultsize unlimited | Set-MailboxRegionalConfiguration –Language en-GB –TimeZone "GMT Standard Time"
    To be:

    Get-Mailbox –Resultsize unlimited | Set-MailboxRegionalConfiguration –Language en-GB –TimeZone "GMT Standard Time" | set-mailboxspellingconfiguration -dictionaryLanguage EnglishUnitedKingdom

    This would set all mailboxes to be in the English UK localisation, with GMT as the standard time zone and English UK as the dictionary language (for spelling, etc.).

    I would run this command only once the first time you create the bulk of your users. For subsequent runs I would write a script that only runs this against mailboxes that haven't already been configured this way - it's a more efficient way of doing it.

  12. Thanks to jamesbmarshall from:

    Michael (26th March 2012)

  13. #10

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,265
    Thank Post
    242
    Thanked 1,575 Times in 1,254 Posts
    Rep Power
    341
    Right here goes:

    I ran the following:

    Code:
    $LiveCred = Get-Credential
    
    $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://ps.outlook.com/powershell/ -Credential $LiveCred -Authentication Basic -AllowRedirection
    
    Import-PSSession $Session
    
    Get-Mailbox –Resultsize unlimited | Set-MailboxRegionalConfiguration –Language en-GB –TimeZone "GMT Standard Time" | set-mailboxspellingconfiguration -dictionaryLanguage EnglishUnitedKingdom
    I'm now receiving the following message:

    WARNING: The operation that's currently running has exceeded your Throttling Policy budget. The operation will be delayed until your budget allows it to proceed. Approximate delay time: "29" seconds.
    This has appeared numerous times. Is this normal and is there anything else I must do?

  14. #11

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,265
    Thank Post
    242
    Thanked 1,575 Times in 1,254 Posts
    Rep Power
    341
    After the throttling message appeared about 10 times, the process then stopped automatically.

    I can confirm both the Time Zone and Dictionary Language changed successfully.

    The strange thing however is if I navigate to Options > See All Options > Settings > Spelling, it still states English (United States)

    If I create a new message, and click the down arrow next to ABC, it does say - Check spelling in this language: English (United Kingdom)

    I presume all this is normal and my work is done?

  15. #12
    jamesbmarshall's Avatar
    Join Date
    Feb 2010
    Location
    Reading, UK
    Posts
    550
    Thank Post
    27
    Thanked 239 Times in 166 Posts
    Rep Power
    88
    Throttling is normal - hence why you shouldn't run big cmds like that; try and break them down.

    Not sure why OWA shows US English, might take some time to update / be a bug. But if creating a new mail shows English UK then you're good to go!

  16. #13

    Join Date
    Jan 2006
    Location
    Surburbia
    Posts
    2,178
    Thank Post
    74
    Thanked 307 Times in 243 Posts
    Rep Power
    115
    Thing is.. writing a script can take a while especially if something you're interested in doing doesn't have perfect documentation, whereas kicking off a simple brute force one-liner and checking it finished when you've returned with a fresh coffee might use some MS CPU cycles, but it doesn't take much of MY time. That said I do like doing this kind of thing because it works for most stuff, fits on one line and spits out less console noise:

    get-mailbox -resultsize unlimited | ?{$_.languages -ne 'en-gb'} | set-mailbox ...

    For a while I used to want to use -filter whenever I could because I suspect that is more efficient, but this reaches more parts and figuring out what is filterable (besides 'name' or a customattribute) can be a pain e.g. can anyone find a working filter for the above?
    Last edited by PiqueABoo; 26th March 2012 at 09:30 PM. Reason: missing space in command

  17. #14


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    9,370
    Thank Post
    241
    Thanked 2,813 Times in 2,076 Posts
    Rep Power
    812
    Quote Originally Posted by PiqueABoo View Post
    For a while I used to want to use -filter whenever I could because I suspect that is more efficient
    You're right actually. It is more efficient. As they say "Filter Left, Format Right".

    The following command will be much faster since you are only retrieving the mailboxes that haven't had their language set to British English...

    Code:
    Get-Mailbox –ResultSize Unlimited -Filter {(RecipientType -eq 'UserMailbox') -and (LanguagesRaw -ne 'en-GB')} | Set-MailboxRegionalConfiguration –Language en-GB –TimeZone 'GMT Standard Time'

  18. #15

    Join Date
    Jan 2006
    Location
    Surburbia
    Posts
    2,178
    Thank Post
    74
    Thanked 307 Times in 243 Posts
    Rep Power
    115
    ::drat:: it's been a while and I'm sure I tried LangaugesRaw but got lots of redness.

    Just checked that it really did work and your filter gets more results than my where-object. The former matches $null, the latter doesn't.

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Live@edu vs. Exchange?
    By Gongalong in forum Cloud Services
    Replies: 41
    Last Post: 15th November 2011, 10:41 AM
  2. Exchange 2010 vs Live@edu
    By leonard.powers in forum How do you do....it?
    Replies: 14
    Last Post: 2nd December 2010, 12:21 AM
  3. Exchange 2010 and live@edu?
    By leco in forum Windows Server 2008 R2
    Replies: 6
    Last Post: 29th September 2010, 08:01 PM
  4. Remote Exchange (& Live@Edu) connectivity testing
    By PiqueABoo in forum Internet Related/Filtering/Firewall
    Replies: 0
    Last Post: 12th September 2010, 04:25 PM
  5. Hotmail & Live@Edu blocking mail from Exchange Server 2003
    By nsherin in forum Windows Server 2000/2003
    Replies: 5
    Last Post: 24th June 2010, 06:28 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •