+ Post New Thread
Results 1 to 10 of 10
Enterprise Software Thread, SharePoint 2010, Visio & SCOM in Technical; I have made a few web drawings that are linked to data in SCOM such as servers, switches. I have ...
  1. #1
    HMCTech's Avatar
    Join Date
    Apr 2008
    Posts
    618
    Thank Post
    37
    Thanked 48 Times in 35 Posts
    Rep Power
    22

    SharePoint 2010, Visio & SCOM

    I have made a few web drawings that are linked to data in SCOM such as servers, switches. I have enabled Visio Graphics Service on SharePoint as per instructions usign a powershell script provided by Microsoft. I am able to upload web drawings and have them render in the browser. But refreshing the data creates the following error

    "An exception occurred communicating with the Operations Manager RMS. Please contact the administrator."

    Not much in the way of help online unfortunately. Has anyone got this to work in their setup?

  2. #2

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,137
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    77
    Hi

    What version of Visio and SCOM are you using?

    Regards
    Sukh

  3. #3
    HMCTech's Avatar
    Join Date
    Apr 2008
    Posts
    618
    Thank Post
    37
    Thanked 48 Times in 35 Posts
    Rep Power
    22
    2010 and SCOM 2007

  4. #4

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,137
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    77
    Hi

    Have you tried reinstalling the visio add-in parts on Sharepoint?

    Regards
    Sukh

  5. #5
    HMCTech's Avatar
    Join Date
    Apr 2008
    Posts
    618
    Thank Post
    37
    Thanked 48 Times in 35 Posts
    Rep Power
    22
    Viso add ins for SharePoint? Do you mean starting the service and creating the application under Service Applications?

  6. #6

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,137
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    77
    Hi

    What I meant was have you run OpsMgrDataModuleSetup.msi again and executed the OpsMgrDataModule.ps1 ?

    Also, have you checked the permission on the application pool?

    Have you also given Visio Services account Read-Only Operator access to the RMS?

    Regards
    Sukh

  7. #7
    HMCTech's Avatar
    Join Date
    Apr 2008
    Posts
    618
    Thank Post
    37
    Thanked 48 Times in 35 Posts
    Rep Power
    22
    Quote Originally Posted by sukh View Post
    Hi

    What I meant was have you run OpsMgrDataModuleSetup.msi again and executed the OpsMgrDataModule.ps1 ?

    Also, have you checked the permission on the application pool?

    Have you also given Visio Services account Read-Only Operator access to the RMS?

    Regards
    Sukh
    Yes, I have run the msi and the powershell went through fine with no errors.

    I know which user is the managed account for the applciation pool that visio service uses. I have added that account as a read only operator in SCOM.

  8. #8

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,137
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    77
    Hi

    Have you tried to re-install this and verified this. See Monitor SharePoint Server by using Visio Services and System Center Operations Manager

    get-spsolution cmdlet. You should see True in the Deployed column next to the opsmgrdatamodule.wsp entry.

    Regards
    Sukh

  9. Thanks to sukh from:

    HMCTech (3rd March 2011)

  10. #9
    HMCTech's Avatar
    Join Date
    Apr 2008
    Posts
    618
    Thank Post
    37
    Thanked 48 Times in 35 Posts
    Rep Power
    22
    Thank you for that link, I sat through the video and my managed account was not actually the one I thought it was so its all working now. Thanks

  11. #10

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,137
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    77
    Hi

    No problem at all.

    Regards
    Sukh

SHARE:
+ Post New Thread

Similar Threads

  1. sharepoint 07 to 2010
    By kevin_lane in forum Virtual Learning Platforms
    Replies: 5
    Last Post: 10th January 2011, 12:59 PM
  2. Sharepoint 2010
    By pritchardavid in forum Windows
    Replies: 8
    Last Post: 11th November 2010, 08:59 AM
  3. SIMS Learning Gateway & Sharepoint 2010
    By mattstevenson2005 in forum Virtual Learning Platforms
    Replies: 5
    Last Post: 9th September 2010, 09:01 AM
  4. SharePoint 2010
    By apearce in forum Virtual Learning Platforms
    Replies: 1
    Last Post: 16th September 2009, 11:32 AM
  5. Sharepoint 2010?
    By zag in forum Virtual Learning Platforms
    Replies: 14
    Last Post: 22nd April 2009, 08:24 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •