+ Post New Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 33
Enterprise Software Thread, Exchange / Outlook 2010 Autodiscover / Outlook Anywhere [Solved] in Technical; at work, all our laptops are now windows 7 and outlook 2010. Our exchange server is 2007. When these laptops ...
  1. #1

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,532
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200

    Exchange / Outlook 2010 Autodiscover / Outlook Anywhere [Solved]

    at work, all our laptops are now windows 7 and outlook 2010. Our exchange server is 2007.

    When these laptops are taken off campus, outlook still connects to exchange and works just as if it was connected locally.

    I have another place, with Exchange 2010 and Outlook 2010, and trying to get the same to work. The only other difference is the latter place is behind a NAT while the first has its own WAN IP. Port 443 is forwarded for OWA, is there anything else that needs done for this to work? At the moment Im having to connect to the VPN before outlook works.

  2. #2

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,956
    Thank Post
    775
    Thanked 1,487 Times in 1,234 Posts
    Rep Power
    367
    You can't use the 443 for connection to exchange. You'll need to open something else, either imap/smtp using tls, forget what it is 537 or something and imap is secured too. Not sure what you need for a direct exchange connection.

    Edit: this article mentions the ports for imap / smtp http://support.microsoft.com/kb/176466 maybe try those and set up an imap connection.

    Though for outlook to connect direct to exchange i think it's saying port 135. Not sure, i'm doing it via live@edu, and with the autodiscover cname entry, external client just works on iPhone and other devices.
    Last edited by vikpaw; 26th January 2011 at 02:42 PM. Reason: edit : add link

  3. #3

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,532
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    This setup is a bit tricky..

    the mail email address is username@emaildomain.com but the actual website domain is webdomain.com so for OWA the login page is https://mail.webdomain.com and the local domain is somethingelse.local and the username@emaildomain.com is set as the primary address in Exchange.

    SMTP is already open and this is the way that it is currently used off site, but I want direct connection not pop/smtp or even IMAP..

    Will have a read of your link and have a play, thanks

  4. #4
    penfold_99's Avatar
    Join Date
    Feb 2008
    Location
    East Sussex
    Posts
    1,003
    Thank Post
    60
    Thanked 167 Times in 119 Posts
    Rep Power
    69
    I have just gone through the process of setting up exchange to allow outlook anywhere. I found this tool very useful as it will pin point the issue that is causing the problem.

    https://www.testexchangeconnectivity.com/

  5. #5

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,532
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Running that, with the Outlook Anywehre test, fails using autodiscover, due to what I said abouve about the email address being different from the exchange domain etc.

    If I run the test again, and Manually specify server settings, it failed with ntlm authentication. If i run again with it set to basic, I get this:

    Code:
    Testing RPC/HTTP connectivity.
     	The RPC/HTTP test failed.
     	
    	Test Steps
     	
    	Attempting to resolve the host name mail.webdomain.co.uk in DNS.
     	The host name resolved successfully.
     	
    	Additional Details
     	IP addresses returned: xx.xx.xx.xx
    	Testing TCP port 443 on host mail.webdomain.co.uk to ensure it's listening and open.
     	The port was opened successfully.
    	Testing the SSL certificate to make sure it's valid.
     	The certificate passed all validation requirements.
     	
    	Test Steps
     	
    	Validating the certificate name.
     	The certificate name was validated successfully.
     	
    	Additional Details
     	Host name mail.webdomain.co.uk was found in the Certificate Subject Common name.
    	Certificate trust is being validated.
     	The test passed with some warnings encountered. Please expand the additional details.
     	
    	Additional Details
     	ExRCA can only validate the certificate chain using the Root Certificate Update functionality from Windows Update. Your certificate may not be trusted on Windows if the "Update Root Certificates" feature isn't enabled.
    	Testing the certificate date to confirm the certificate is valid.
     	Date validation passed. The certificate hasn't expired.
     	
    	Additional Details
     	The certificate is valid. NotBefore = 4/28/2010 3:57:42 PM, NotAfter = 4/30/2011 2:31:59 AM
    	Checking the IIS configuration for client certificate authentication.
     	Client certificate authentication wasn't detected.
     	
    	Additional Details
     	Accept/Require Client Certificates isn't configured.
    	Testing HTTP Authentication Methods for URL https://mail.webdomain.co.uk/rpc/rpcproxy.dll.
     	The HTTP authentication methods are correct.
     	
    	Additional Details
     	ExRCA found all expected authentication methods and no disallowed methods. Methods found: Basic
    	Testing SSL mutual authentication with the RPC proxy server.
     	Mutual authentication was verified successfully.
     	
    	Additional Details
     	Certificate common name mail.webdomain.co.uk matches msstd:mail.webdomain.co.uk.
    	Attempting to ping RPC proxy mail.webdomain.co.uk.
     	RPC Proxy can't be pinged.
     	
    	Additional Details
     	A Web exception occurred because an HTTP 440 - 440 response was received from Unknown.

  6. #6
    penfold_99's Avatar
    Join Date
    Feb 2008
    Location
    East Sussex
    Posts
    1,003
    Thank Post
    60
    Thanked 167 Times in 119 Posts
    Rep Power
    69
    Do you have autodiscover.webdomain.com setup and pointing at your email server ip address?

    Who is the provider your SSL certificate? You may need to install the intermediate root certificate on your server.

  7. #7

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,532
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    StartCom LTD SSL profide the cert..

    and yeh, theres an A record autodiscover.webdomain.com pointing to the server IP

    there isnt a record for autodiscover.emaildomain.com .. should there be?

  8. #8
    penfold_99's Avatar
    Join Date
    Feb 2008
    Location
    East Sussex
    Posts
    1,003
    Thank Post
    60
    Thanked 167 Times in 119 Posts
    Rep Power
    69
    autodiscover should be on the same domain as webdomain.com/owa

    I think the analyser is trying to validate the certificate against the one in windows trusted root but the certificate that forms the chain between the one on your machine and the root certificate is missing.
    To add the missing certificate have a look here. StartSSL

  9. #9

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,532
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    but it is passing all the certificate stuff ?

    THis is where it fails:

    Attempting to ping RPC proxy mail.webdomain.co.uk.
    RPC Proxy can't be pinged.

    Additional Details
    A Web exception occurred because an HTTP 440 - 440 response was received from Unknown.

  10. #10
    penfold_99's Avatar
    Join Date
    Feb 2008
    Location
    East Sussex
    Posts
    1,003
    Thank Post
    60
    Thanked 167 Times in 119 Posts
    Rep Power
    69
    silly question but have you enable outlook anyhwere on your exchange server?

  11. #11

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,532
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    umm.... let me check..

  12. #12

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,532
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    yes it seems to be.. as theres an option to "disable outlook anywhere"

    anyway, 4am now.. ill take this up again tomorrow.. cheers for you rhelp

  13. #13

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,532
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    I think I have fixed it!

    on the RPC vdir in IIS, the redirection had been ticked, and nothing was entered. Unticking the redirection fixed it.

    Found the answer here: Exchange 2010 Outlook Anywhere

  14. #14

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,532
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    also had to reconfigure outlook too to enable the anywhere option

  15. #15

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,532
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Quote Originally Posted by vikpaw View Post
    You can't use the 443 for connection to exchange. You'll need to open something else, either imap/smtp using tls, forget what it is 537 or something and imap is secured too. Not sure what you need for a direct exchange connection.

    Edit: this article mentions the ports for imap / smtp TCP ports and Microsoft Exchange: In-depth discussion maybe try those and set up an imap connection.

    Though for outlook to connect direct to exchange i think it's saying port 135. Not sure, i'm doing it via live@edu, and with the autodiscover cname entry, external client just works on iPhone and other devices.
    by the way, it looks like outlook anywhere uses https (443) after all

    Configure Outlook Anywhere in Outlook 2010

  16. Thanks to RabbieBurns from:

    vikpaw (26th January 2011)



SHARE:
+ Post New Thread
Page 1 of 3 123 LastLast

Similar Threads

  1. Exchange outlook webapp 2010 timeout
    By ful56_uk in forum Internet Related/Filtering/Firewall
    Replies: 9
    Last Post: 14th March 2011, 08:39 PM
  2. Exchange 2010 Autodiscover
    By skell in forum Enterprise Software
    Replies: 4
    Last Post: 20th January 2011, 12:18 PM
  3. Replies: 0
    Last Post: 25th October 2010, 09:23 PM
  4. Exchange 2007 / Outlook 2010 Certificate Error
    By craigg in forum Windows Server 2000/2003
    Replies: 1
    Last Post: 20th October 2010, 03:10 PM
  5. outlook 2007 archiving with Exchange 2010
    By ful56_uk in forum Internet Related/Filtering/Firewall
    Replies: 0
    Last Post: 20th October 2010, 10:51 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •