+ Post New Thread
Results 1 to 8 of 8
Enterprise Software Thread, SCCM 2012 Application Deployment headache in Technical; I am trying to deploy Writeonline as application it deploys fine as an available piece of software but when i ...
  1. #1
    akidosaint's Avatar
    Join Date
    Sep 2008
    Location
    Peterborough
    Posts
    185
    Thank Post
    125
    Thanked 21 Times in 20 Posts
    Rep Power
    21

    SCCM 2012 Application Deployment headache

    I am trying to deploy Writeonline as application it deploys fine as an available piece of software but when i try to deploy it as Required piece of software it fails.

    in the appenforce.log i get the following error

    CMsiHandler::EnforceApp failed (0x80070005).
    AppProvider::EnforceApp - Failed to invoke EnforceApp on Application handler(0x80070005).
    CommenceEnforcement failed with error 0x80070005.
    Method CommenceEnforcement failed with error code 80070005
    ++++++ Failed to enforce app. Error 0x80070005. ++++++

    Permissions to folder are the same as other applications that deploy fine.

    i tried to deploy via a .bat script still same issue.

  2. #2

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,157
    Thank Post
    522
    Thanked 2,552 Times in 1,981 Posts
    Blog Entries
    24
    Rep Power
    877
    Is it installing per user or per system? When you say it works when you make it available, does it work only as an admin or does it work as a non-admin user?

  3. #3

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,772
    Thank Post
    873
    Thanked 674 Times in 443 Posts
    Rep Power
    503
    IIRC, doesn't it use the SYSTEM account for doing this?

  4. #4

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,157
    Thank Post
    522
    Thanked 2,552 Times in 1,981 Posts
    Blog Entries
    24
    Rep Power
    877
    It does, but if its a user-specific installer (eg. an MSI that is user specific), the install can fail if deployed by machine rather than to a user. Its rare, and annoying, but can happen.

  5. #5
    akidosaint's Avatar
    Join Date
    Sep 2008
    Location
    Peterborough
    Posts
    185
    Thank Post
    125
    Thanked 21 Times in 20 Posts
    Rep Power
    21
    Software is deployed to system. Staff have permissions to do the install via sccm. Trying to push out to all student machines rather than users as students do not have device affinity setup.
    Last edited by akidosaint; 11th December 2013 at 03:23 PM.

  6. #6
    akidosaint's Avatar
    Join Date
    Sep 2008
    Location
    Peterborough
    Posts
    185
    Thank Post
    125
    Thanked 21 Times in 20 Posts
    Rep Power
    21
    I will speak with software provider tomorrow about this issue not holding out much hope. Creating a package from definition to see that makes any difference.

  7. #7
    free780's Avatar
    Join Date
    Sep 2012
    Posts
    1,062
    Thank Post
    45
    Thanked 86 Times in 81 Posts
    Rep Power
    23
    So allusers=1 doesn't help on the command line or part of a mst? You could try starting a cmd as system using psexec. You need to map a drive using your network access account.

  8. #8
    akidosaint's Avatar
    Join Date
    Sep 2008
    Location
    Peterborough
    Posts
    185
    Thank Post
    125
    Thanked 21 Times in 20 Posts
    Rep Power
    21
    After speaking to support problem was that shared resource file that deployment pointed wasn't accessible made it proper share and hey presto it works

SHARE:
+ Post New Thread

Similar Threads

  1. SCCM 2012 - Software deployment
    By pettit87 in forum Enterprise Software
    Replies: 11
    Last Post: 24th February 2014, 08:34 PM
  2. SCCM 2012 - Driver Deployment
    By synaesthesia in forum Enterprise Software
    Replies: 1
    Last Post: 7th November 2012, 09:25 AM
  3. SCCM 2012 Application Deployment Issues
    By broadld in forum Enterprise Software
    Replies: 3
    Last Post: 12th October 2012, 09:25 AM
  4. SCCM 2012 software deployment issues
    By imunro01 in forum Enterprise Software
    Replies: 8
    Last Post: 7th September 2012, 07:20 AM
  5. SCCM 2012: Ordering Deployments
    By Mr.Ben in forum Enterprise Software
    Replies: 6
    Last Post: 27th June 2012, 04:23 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •