+ Post New Thread
Results 1 to 7 of 7
EduSweep Thread, Bug in Projects:; I've just had an unhandled exception (Object reference not set to an instance of an object). I viewed a scan ...
  1. #1

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,867
    Thank Post
    412
    Thanked 778 Times in 651 Posts
    Rep Power
    182

    Bug

    I've just had an unhandled exception (Object reference not set to an instance of an object).

    I viewed a scan log that had no results, clicked 'Finish and Close', and the stack threw:

    System.NullReferenceException: Object reference not set to an instance of an object.
    at System.Windows.Forms.ToolStripProgressBar.set_Valu e(Int32 value)
    at EduSweep.ResultsViewer.backgroundWorkerPopulate_Pr ogressChanged(Object sender, ProgressChangedEventArgs e) in C:\Users\Paul\Visual Studio 2008\Projects\EduSweep\Script Spy\ResultsViewer.cs:line 535
    at System.ComponentModel.BackgroundWorker.OnProgressC hanged(ProgressChangedEventArgs e)
    at System.ComponentModel.BackgroundWorker.ProgressRep orter(Object arg)

  2. Thanks to powdarrmonkey from:

    bizzel (26th September 2008)

  3. #2
    bizzel's Avatar
    Join Date
    Jul 2007
    Location
    Cambridge
    Posts
    654
    Thank Post
    102
    Thanked 204 Times in 72 Posts
    Rep Power
    52
    Oooh, okay. I think that's the first bug I've had reported so far! I'll try to reproduce it here.

    Update: I've looked at the code and that line is this method here

    Code:
            private void backgroundWorkerPopulate_ProgressChanged(object sender, ProgressChangedEventArgs e)
            {
                toolStripProgressBarPopulate.Value = e.ProgressPercentage;
            }
    Quite why this would be firing on close, I'm not sure. I couldn't reproduce the bug on this system but I can see why it might cause a crash. I'll get to patching it.
    Last edited by bizzel; 26th September 2008 at 12:44 PM.

  4. #3

    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    127
    Thank Post
    27
    Thanked 15 Times in 14 Posts
    Rep Power
    15
    I got another bug for you, sorry. Happened after I downloaded 2.1 and installed. Occurs whenever i click create new signature, new task, everything really. Here the error details

    Code:
    See the end of this message for details on invoking 
    just-in-time (JIT) debugging instead of this dialog box.
    
    ************** Exception Text **************
    System.ComponentModel.Win32Exception: The parameter is incorrect
       at System.Drawing.BufferedGraphicsContext.CreateCompatibleDIB(IntPtr hdc, IntPtr hpal, Int32 ulWidth, Int32 ulHeight, IntPtr& ppvBits)
       at System.Drawing.BufferedGraphicsContext.CreateBuffer(IntPtr src, Int32 offsetX, Int32 offsetY, Int32 width, Int32 height)
       at System.Drawing.BufferedGraphicsContext.AllocBuffer(Graphics targetGraphics, IntPtr targetDC, Rectangle targetRectangle)
       at System.Drawing.BufferedGraphicsContext.Allocate(IntPtr targetDC, Rectangle targetRectangle)
       at System.Windows.Forms.Control.WmPaint(Message& m)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.Label.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    
    
    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
        CodeBase: file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    ----------------------------------------
    EduSweep 2
        Assembly Version: 2.0.0.1165
        Win32 Version: 2.0.0.1165
        CodeBase: file:///C:/Program%20Files/EduSweep%202/EduSweep%202.exe
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Configuration
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    ----------------------------------------
    System.Xml
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.1433 (REDBITS.050727-1400)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------
    System.Xml.Linq
        Assembly Version: 3.5.0.0
        Win32 Version: 3.5.21022.8 built by: RTM
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml.Linq/3.5.0.0__b77a5c561934e089/System.Xml.Linq.dll
    ----------------------------------------
    System.Core
        Assembly Version: 3.5.0.0
        Win32 Version: 3.5.21022.8 built by: RTM
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Core/3.5.0.0__b77a5c561934e089/System.Core.dll
    ----------------------------------------
    
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    
    For example:
    
    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>
    
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
    PS this software is great and saves me a load a time at work, thank you very much

  5. Thanks to Wils86 from:

    bizzel (19th March 2009)

  6. #4
    bizzel's Avatar
    Join Date
    Jul 2007
    Location
    Cambridge
    Posts
    654
    Thank Post
    102
    Thanked 204 Times in 72 Posts
    Rep Power
    52
    Thanks for reporting it. Can I check a few details?

    * Does the main window appear okay?
    * What OS are you running?
    * Could you try clearing the contents of the Tasks and Signatures directories inside the EduSweep folder and see what happens?

  7. Thanks to bizzel from:

    Wils86 (20th March 2009)

  8. #5

    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    127
    Thank Post
    27
    Thanked 15 Times in 14 Posts
    Rep Power
    15
    Hi Bizzle, the window appeared but looked like there was a clear bar accross the top of it showing the desktop. The problem has being solved partly as i uninstalled and reinstalled it. But now it seems not matter what signatures I use it only searches jpg's (strange i know).

    Im using xp pro sp3 fully patched.

    edit: scratch that last problem, cleared the tasks and signatures folders and did a software update, works perfectly again cheers again
    Last edited by Wils86; 20th March 2009 at 11:32 AM.

  9. #6
    bizzel's Avatar
    Join Date
    Jul 2007
    Location
    Cambridge
    Posts
    654
    Thank Post
    102
    Thanked 204 Times in 72 Posts
    Rep Power
    52
    Hi again,

    On Vista the program uses a glass effect on the titlebar (you can turn it off of course!) but it sounds like it's trying to enable on XP as well which is something I haven't seen before. Even if you go into the settings and enable glass it should stay disabled on XP - perhaps it doesn't?

    Let me know if the signature problem occurs again - I'm doing a lot of work to the guts in 2.2 and I can always roll in another fix.

    Quote Originally Posted by Wils86 View Post
    Hi Bizzle, the window appeared but looked like there was a clear bar accross the top of it showing the desktop. The problem has being solved partly as i uninstalled and reinstalled it. But now it seems not matter what signatures I use it only searches jpg's (strange i know).

    Im using xp pro sp3 fully patched.

    edit: scratch that last problem, cleared the tasks and signatures folders and did a software update, works perfectly again cheers again

  10. Thanks to bizzel from:

    Wils86 (23rd March 2009)

  11. #7
    bizzel's Avatar
    Join Date
    Jul 2007
    Location
    Cambridge
    Posts
    654
    Thank Post
    102
    Thanked 204 Times in 72 Posts
    Rep Power
    52
    These bugs should be fixed in the next patch - 2.1.1. I hope to have that ready in the next couple of weeks. Slow progress of late, I've been tied up with AUP Informant 2.



SHARE:
+ Post New Thread

Similar Threads

  1. Is this a bug or a feature?
    By SeanVin in forum Wireless Networks
    Replies: 1
    Last Post: 17th July 2008, 03:51 AM
  2. Netsupport Bug!!
    By tekkee in forum Network and Classroom Management
    Replies: 4
    Last Post: 18th June 2008, 02:48 PM
  3. Possible bug in simple template
    By SimpleSi in forum EduGeek Joomla 1.5 Package
    Replies: 0
    Last Post: 2nd June 2008, 08:05 AM
  4. Bitten by the eBay Bug!!
    By Gatt in forum General Chat
    Replies: 8
    Last Post: 14th April 2008, 11:14 PM
  5. WMF Bug
    By russdev in forum Windows
    Replies: 27
    Last Post: 12th January 2006, 11:29 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •