+ Post New Thread
Results 1 to 3 of 3
EduGeek Joomla 1.5 Package Thread, Topmenu disappearing behind media content in Projects:; Hi, I've got a bad case of disappearing top menu (mainmenu). Occasionaly when selected the dropdown hides behind the picture ...
  1. #1

    Join Date
    Jan 2010
    Posts
    175
    Thank Post
    25
    Thanked 3 Times in 2 Posts
    Rep Power
    10

    Topmenu disappearing behind media content

    Hi,

    I've got a bad case of disappearing top menu (mainmenu). Occasionaly when selected the dropdown hides behind the picture slideshow, but that's easily remedied with an F5.

    However it always goes behind a video window (I'm using AllVideo's jwplayer) and it won't revert to correctly displaying on F5. See screenshot.

    I've looked around the AllVideo extension documentation to no avail.

    Anyone know a fix? Is there a way in CSS or HTML to say to the topmenu 'always on top' or 'bring to the front' perhaps?

    Topmenu disappearing behind media content-probwithmenuandjwplayerarrow.png

  2. #2

    Join Date
    Jan 2010
    Posts
    175
    Thank Post
    25
    Thanked 3 Times in 2 Posts
    Rep Power
    10
    Ok, so looking a bit further into this it might have something to do with z-indexing.

    The topmenu has a z-index of 100 in the template.css which means it should always remain on top unless further down the page another element has a z-index of 100 too.

    The video appears in the welcome page article. If I'm on the right track with this I'm wondering where I find the z-index of front page articles?

  3. #3

    Join Date
    Jan 2010
    Posts
    175
    Thank Post
    25
    Thanked 3 Times in 2 Posts
    Rep Power
    10
    May have fixed it. I added position: relative and z-index: 80 to .containerheader in the template.css and now the article (with the video) sits behind the dropdown menu.

SHARE:
+ Post New Thread

Similar Threads

  1. Change position of topmenu
    By sarchs in forum EduGeek Joomla 1.5 Package
    Replies: 21
    Last Post: 12th May 2012, 10:14 AM
  2. topmenu - mainmenu
    By jann in forum EduGeek Joomla 1.5 Package
    Replies: 9
    Last Post: 9th March 2011, 10:14 AM
  3. Serving media content using IIS
    By Edu-IT in forum Windows
    Replies: 4
    Last Post: 4th February 2011, 06:53 PM
  4. Printer disappearing
    By witch in forum Windows Server 2008 R2
    Replies: 0
    Last Post: 31st January 2011, 12:43 PM
  5. Replies: 17
    Last Post: 9th November 2008, 11:59 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •