+ Post New Thread
Results 1 to 15 of 15
EduGeek Joomla 1.5 Package Thread, Website launched - have a look please :) in Projects:; Just moved new website from development to live folder. Any feedback much appreciated Welcome to the Frontpage Thanks...
  1. #1

    sparkeh's Avatar
    Join Date
    May 2007
    Posts
    7,225
    Thank Post
    1,441
    Thanked 1,859 Times in 1,252 Posts
    Blog Entries
    22
    Rep Power
    559

    Website launched - have a look please :)

    Just moved new website from development to live folder.

    Any feedback much appreciated

    Welcome to the Frontpage

    Thanks

  2. Thanks to sparkeh from:

    speckytecky (17th April 2009)

  3. #2

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    Boston, MA
    Posts
    7,601
    Thank Post
    110
    Thanked 771 Times in 599 Posts
    Rep Power
    183
    Nice... Very clean looking! Easy on the eyes, although some of the text could maybe do with being slightly darker.

  4. Thanks to Ric_ from:

    sparkeh (16th April 2009)

  5. #3

    SYSMAN_MK's Avatar
    Join Date
    Sep 2005
    Posts
    4,012
    Thank Post
    490
    Thanked 1,345 Times in 731 Posts
    Rep Power
    429
    Good use of the package. Like it.

  6. Thanks to SYSMAN_MK from:

    sparkeh (16th April 2009)

  7. #4

    NikChillin's Avatar
    Join Date
    Nov 2007
    Location
    on the sofa
    Posts
    1,007
    Thank Post
    78
    Thanked 137 Times in 100 Posts
    Rep Power
    127
    Quote Originally Posted by Ric_ View Post
    Nice... Very clean looking! Easy on the eyes, although some of the text could maybe do with being slightly darker.
    I agree, it is very nicely done. I think the login box should be at the top though.

  8. Thanks to NikChillin from:

    sparkeh (16th April 2009)

  9. #5
    alan-d's Avatar
    Join Date
    Aug 2005
    Location
    Sutton Coldfield
    Posts
    2,422
    Thank Post
    360
    Thanked 259 Times in 190 Posts
    Rep Power
    77
    I agree with the above re the login box and darker text. I'm not a fan of the big headers but otherwise a nice site

  10. Thanks to alan-d from:

    sparkeh (16th April 2009)

  11. #6

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,452
    Thank Post
    408
    Thanked 671 Times in 613 Posts
    Rep Power
    192
    You hosted on Web2 by any chance? Site won't load for me and nor will my schools site.

  12. Thanks to Edu-IT from:

    sparkeh (17th April 2009)

  13. #7

    featured_spectre's Avatar
    Join Date
    Nov 2008
    Posts
    12,498
    Thank Post
    1,684
    Thanked 2,053 Times in 1,491 Posts
    Blog Entries
    2
    Rep Power
    463
    same here, doesnt load....

  14. Thanks to featured_spectre from:

    sparkeh (17th April 2009)

  15. #8
    mossj's Avatar
    Join Date
    Dec 2008
    Location
    Leicester
    Posts
    1,466
    Thank Post
    157
    Thanked 189 Times in 174 Posts
    Rep Power
    53
    I get cannot display page.... 11.44pm (still offline as of 12.37am)

    Also (from looking at the link) consider using a SEO ext so you get better headers (I.E Schools Name - Homepage), just makes your search rank a little bit higher
    Last edited by mossj; 17th April 2009 at 01:27 AM.

  16. Thanks to mossj from:

    sparkeh (17th April 2009)

  17. #9

    sparkeh's Avatar
    Join Date
    May 2007
    Posts
    7,225
    Thank Post
    1,441
    Thanked 1,859 Times in 1,252 Posts
    Blog Entries
    22
    Rep Power
    559
    Quote Originally Posted by Edu-IT View Post
    You hosted on Web2 by any chance?
    Bingo!
    Been up and down for a while. Just as I went to proudly show it to boss we got the unavailable message

    Seems to be up again now though. *fingers crossed*

  18. #10
    mossj's Avatar
    Join Date
    Dec 2008
    Location
    Leicester
    Posts
    1,466
    Thank Post
    157
    Thanked 189 Times in 174 Posts
    Rep Power
    53
    You could change the favicon to something other than the joomla one, would make it look slightly more professional. Also it looks like you haven't changed the meta discriptions (done in system settings in the backend).

    Also consider turning on breadcrumbs, it helps alot with users navigating your site and stops them getting the horrible 'lost' feeling.

    but looks good
    Last edited by mossj; 17th April 2009 at 04:22 PM.

  19. Thanks to mossj from:

    sparkeh (17th April 2009)

  20. #11

    sparkeh's Avatar
    Join Date
    May 2007
    Posts
    7,225
    Thank Post
    1,441
    Thanked 1,859 Times in 1,252 Posts
    Blog Entries
    22
    Rep Power
    559
    Quote Originally Posted by mossj View Post
    You could change the favicon to something other than the joomla one, would make it look slightly more professional. Also it looks like you haven't changed the meta discriptions (done in system settings in the backend)
    You are quite right - thanks for that, I had forgotten.
    I'll add those to the list.

  21. #12

    Join Date
    Jan 2009
    Location
    England
    Posts
    1,406
    Thank Post
    306
    Thanked 307 Times in 265 Posts
    Rep Power
    82
    Have to say it looks very nice and clean

  22. Thanks to Soulfish from:

    sparkeh (17th April 2009)

  23. #13

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,452
    Thank Post
    408
    Thanked 671 Times in 613 Posts
    Rep Power
    192
    I'd also reverse the order of the navigation.

  24. Thanks to Edu-IT from:

    sparkeh (17th April 2009)

  25. #14

    ZeroHour's Avatar
    Join Date
    Dec 2005
    Location
    Edinburgh, Scotland
    Posts
    5,832
    Thank Post
    971
    Thanked 1,385 Times in 849 Posts
    Blog Entries
    1
    Rep Power
    457
    One really small issue, well tweak really, would be to specifiy the dimensions of the *banner* image rotator. I live it when a page lays its self out while the content loads rather then after the content arrives.
    Other wise its nice

  26. Thanks to ZeroHour from:

    sparkeh (17th April 2009)

  27. #15

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,452
    Thank Post
    408
    Thanked 671 Times in 613 Posts
    Rep Power
    192

  28. Thanks to Edu-IT from:

    sparkeh (17th April 2009)



SHARE:
+ Post New Thread

Similar Threads

  1. New Website
    By itgeek2008 in forum Web Development
    Replies: 10
    Last Post: 6th April 2009, 04:35 PM
  2. Elonex ONE Launched
    By SimpleSi in forum Hardware
    Replies: 10
    Last Post: 29th February 2008, 11:11 AM
  3. Joomla! 1.5 Launched
    By Diello in forum IT News
    Replies: 7
    Last Post: 24th January 2008, 10:54 AM
  4. Media Player 11 Launched
    By john in forum Windows
    Replies: 8
    Last Post: 31st October 2006, 09:21 PM
  5. New website
    By Norphy in forum Web Development
    Replies: 8
    Last Post: 31st March 2006, 02:31 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •