+ Post New Thread
Results 1 to 2 of 2
EduGeek Joomla 1.5 Package Thread, DOCMan (& DOCLink) Issues - Joomla 1.5.7 in Projects:; Hi, Installed EGJP 1.5.3 a few months back and since upgraded to Joomla 1.5.7. I've got my website virtually all ...
  1. #1

    Join Date
    Dec 2007
    Posts
    889
    Thank Post
    94
    Thanked 165 Times in 140 Posts
    Rep Power
    50

    DOCMan (& DOCLink) Issues - Joomla 1.5.7

    Hi,

    Installed EGJP 1.5.3 a few months back and since upgraded to Joomla 1.5.7.

    I've got my website virtually all completed, and decided to use DocMan 1.4 RC3 (that was included in the EGJP package) to manage documents.

    I've added files, configured 'documents' etc and made permissions so that everybody can view / read files.

    The articles were created using JCE 1.5.0 (originally beta version as per original EGJP package, but have since upgraded to 1.5.0 stable) and documents were inserted using the "DOCLink" button.

    The problems / issues i've noticed are:

    1) Whilst using DOCLink and you include the document icon, instead of an icon reflecting the document type it just inserts a plain generic icon, even if it is a .PDF file for example. Is it meant to insert a 16x16 icon of file type? The 32x32 file type icon displays fine when using DOCMan from the front end.

    2) Although all files / documents etc are set up as "everybody" can view and read etc, when i browse the website and click on a link (created by DOCLink) within an article it states "To access the private area of this site, please log in. " and i can only view it by entering a registered user account credential.
    This can't be correct. I've ftp'd into the folder "dmdocuments" and public has read access, the only difference I can see is that the owner of the files added via DOCMan is different from those files ftp'd over.

    3) Finally, if i edit an article using JCE Editor from the Admin back end, when i use DOCLink the icon to go up a folder level is missing and just says UP, where as if i edit an article from the front end the icon is correctly shown!

    Any ideas / suggestions?

    Thanking you in advance.

    Note:
    Just found someone with similar problem
    http://forum.joomla.org/viewtopic.ph...st=0&sk=t&sd=a
    Last edited by MYK-IT; 24th October 2008 at 02:22 AM.

  2. #2

    Join Date
    Dec 2007
    Posts
    889
    Thank Post
    94
    Thanked 165 Times in 140 Posts
    Rep Power
    50


    Hi,

    Just wondered if anyone had any ideas??

    Just seems quite a fundamental fault that a document stored within DocMan, with 'Everybody' access rights, cannot be accessed via a Doclink within the webpage without being asked to log in due to accessing a private area!!

    I'm hoping it's just a file / permission error that can rectified???

    Thanking in advance....



SHARE:
+ Post New Thread

Similar Threads

  1. DOCman Uploading error
    By randle in forum EduGeek Joomla 1.0 Package
    Replies: 6
    Last Post: 18th June 2013, 01:00 PM
  2. Using Docman in Joomla?
    By reggiep in forum EduGeek Joomla 1.5 Package
    Replies: 11
    Last Post: 28th July 2009, 12:57 PM
  3. Joomla & AD
    By Zorba in forum EduGeek Joomla 1.5 Package
    Replies: 6
    Last Post: 28th August 2008, 05:12 PM
  4. networking PDA's & security issues
    By projector1 in forum Hardware
    Replies: 3
    Last Post: 12th April 2008, 11:18 AM
  5. Macs & Networking Issues
    By edusites in forum Mac
    Replies: 8
    Last Post: 3rd February 2008, 12:10 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •