+ Post New Thread
Results 1 to 6 of 6
EduGeek Joomla 1.5 Package Thread, User / user manager problem after migration in Projects:; Well - my migration of a site from 1.0 to 1.5 didn't 100% work I'm having problems with users/ user ...
  1. #1

    SimpleSi's Avatar
    Join Date
    Jun 2005
    Location
    Lancashire
    Posts
    5,808
    Thank Post
    1,476
    Thanked 592 Times in 444 Posts
    Rep Power
    168

    User / user manager problem after migration

    Well - my migration of a site from 1.0 to 1.5 didn't 100% work

    I'm having problems with users/ user manager.

    I went to login front end of site (as user teacher) and all the front page modules vanished just leaving the content.

    No logout button visible.

    When I went into user manager, it said that user teacher had never been used.

    Tried creating a new user but after I click on the new button- nothing happens

    If I try to logon with no user name (just accidently clicked it by mistake) I get the same effect as if I'd tried using teacher.

    logon as admin -same again.

    Admin logon works fine in backend. (thank goodness)

    Now all of this happened after creating a new 1.5 site in a subfolder with a different sql prefix- migrating the content from the old 1.0 site - and then moving the new site down to root and altering a few params in configuration.php to get it back working again.

    I don't know at what point it went up the swanee as I didn't test front end logon at intermediate stages.

    I've just tried using mtwmigrator to just import users from old site but that didn't make any difference.

    Any ideas anyone?
    Can i just re-install some user manager module?

    regards

    Simon

  2. #2
    alonebfg's Avatar
    Join Date
    Aug 2006
    Location
    south west some of the time
    Posts
    834
    Thank Post
    12
    Thanked 34 Times in 21 Posts
    Blog Entries
    5
    Rep Power
    24
    as i have previously said this package is not designed to be migrated to as it Is not as easy as a normal migrate and so if you want to use this package it is best to start from scratch as a lot of modules and components have changed.

  3. #3

    SimpleSi's Avatar
    Join Date
    Jun 2005
    Location
    Lancashire
    Posts
    5,808
    Thank Post
    1,476
    Thanked 592 Times in 444 Posts
    Rep Power
    168
    as i have previously said this package is not designed to be migrated to as it Is not as easy as a normal migrate and so if you want to use this package it is best to start from scratch as a lot of modules and components have changed.
    I don't think you have read my migration walkthrough on the wiki yet

    I create a new egJP 1.5.3 site and then just migrate content - no modules/menus/extensions/mambots/wombats or anything else

    It lets anyone migrate over as long as they don't mind a bit of keyboard, mouse and FTP work afterwards

    I've solved the front end logon problem (it was a setting on the login module - I needed to change the login redirection page to the default, changing it to - select item - instead of Home works (don't know why yet) so I'll leave it for the moment.

    regards

    Simon
    Last edited by SimpleSi; 8th June 2008 at 10:29 PM.

  4. #4

    SimpleSi's Avatar
    Join Date
    Jun 2005
    Location
    Lancashire
    Posts
    5,808
    Thank Post
    1,476
    Thanked 592 Times in 444 Posts
    Rep Power
    168
    Well - it seems i can create new users fine in IE6 - just not Firefox (at least not here on FF3)

    My 1.5.2 site works fine and my local 1.5.3 install also works fine in FF3

    Strange one - but since my "customer" i.e the head uses IE7 then I'm good to go

    I'll bet it'll be fine next time I reboot or reload FF
    regards

    Simon

  5. #5
    alonebfg's Avatar
    Join Date
    Aug 2006
    Location
    south west some of the time
    Posts
    834
    Thank Post
    12
    Thanked 34 Times in 21 Posts
    Blog Entries
    5
    Rep Power
    24
    Can I just say the way you have done the migration is not safe as one thing the modules translate in different ways the way you have done it is not safe and i would not recommend that it be done that way. It took months to get the package right and the modules affect the content. For example the editor used is different. And links wont work. This is why this package is not and never will be designed to migrate to.

  6. #6

    SimpleSi's Avatar
    Join Date
    Jun 2005
    Location
    Lancashire
    Posts
    5,808
    Thank Post
    1,476
    Thanked 592 Times in 444 Posts
    Rep Power
    168
    I've done three migrations so far, one on a local test server to prove the concept - one with a downloaded copy of a real site with real content and one over the weekend with the real site itself.

    Which is Broad Oak Primary School BTW

    Please try out my instructions and then if you do find that there is a real problem with them - let me know and I'll try and fix it or delete the wiki

    regards

    Simon
    Last edited by SimpleSi; 10th June 2008 at 07:16 AM.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 1
    Last Post: 22nd May 2008, 11:36 AM
  2. FMS .net User Problem
    By madslug in forum MIS Systems
    Replies: 8
    Last Post: 19th May 2008, 09:37 AM
  3. Replies: 0
    Last Post: 17th February 2008, 12:58 AM
  4. User areas + User share permissions.
    By Dos_Box in forum Windows
    Replies: 6
    Last Post: 11th September 2007, 11:17 AM
  5. AD User Manager
    By Dos_Box in forum Downloads
    Replies: 0
    Last Post: 27th September 2005, 09:56 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •