+ Post New Thread
Results 1 to 9 of 9
EduGeek Joomla 1.5 Package Thread, Read more - help please in Projects:; I have a Read more link on my front page, but when you click it, it opens as a seperate ...
  1. #1
    callmeroy1's Avatar
    Join Date
    Mar 2012
    Location
    Walton, Surrey
    Posts
    7
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Read more - help please

    I have a Read more link on my front page, but when you click it, it opens as a seperate page, with no modules.

    RES

    I have another Read more link on a different page, that works correctly.

    Sixth Form Frontpage

    They are on different templates, but within the same Joomla install.

    Can anyone point me in the right direction as to what or where I need to be looking at to change how the Read more link works.

    Thanks

  2. #2

    Join Date
    Jun 2010
    Posts
    198
    Thank Post
    9
    Thanked 25 Times in 24 Posts
    Rep Power
    21
    Are you using two different templates for different pages? Each template is coded differently. You would need to go to the css file for the template that you want to change. There may be a number of css files for any given template.

    Templates are usually stored in /public_html/templates/name of your template or www/templates/name of your template .

    You would need to find the appropriate line in the css file something link an onclick event or similar.

    Download a copy of your template folder before making in changes just in case it goes *** up

    kili

  3. #3
    callmeroy1's Avatar
    Join Date
    Mar 2012
    Location
    Walton, Surrey
    Posts
    7
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have compared the css files for both templates and they are the same, but only seem to define how the Read more link looks, rather than how it behaves.

    I have added some Read more links to another section that uses the same template as the Frontpage, and these work fine...

    Business & Enterprise News

    It is as if the Frontpage Blog menu option is the problem, rather than the Read more link itself?

  4. #4

    Join Date
    Jun 2010
    Posts
    198
    Thank Post
    9
    Thanked 25 Times in 24 Posts
    Rep Power
    21
    Quote Originally Posted by callmeroy1 View Post
    I have compared the css files for both templates and they are the same, but only seem to define how the Read more link looks, rather than how it behaves.

    I have added some Read more links to another section that uses the same template as the Frontpage, and these work fine...

    Business & Enterprise News

    It is as if the Frontpage Blog menu option is the problem, rather than the Read more link itself?

    It sounds as though when you created the link you may have selected an option to open in a new window. Delete the link and create a new one, that may solve your problem.

    Kili

  5. #5

    Join Date
    Jun 2010
    Posts
    198
    Thank Post
    9
    Thanked 25 Times in 24 Posts
    Rep Power
    21
    Looking at your site I see your still on a 1.5 variant. I recommend you upgrade as soon as you can. I also suggest to block attempts on your login page that you password protect /public_html/administrator or www/administrator whichever you use.

    Kili

  6. #6
    callmeroy1's Avatar
    Join Date
    Mar 2012
    Location
    Walton, Surrey
    Posts
    7
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thank you for your help so far.

    I inherited the site and am still learning Joomla, so will have to look at upgrading and do a bit of homework.

    I have had a quick look at blocking the attempts to login and it appears to be an extention option, rather than an inbuilt one, is that right?

  7. #7

    Join Date
    Jun 2010
    Posts
    198
    Thank Post
    9
    Thanked 25 Times in 24 Posts
    Rep Power
    21
    Quote Originally Posted by callmeroy1 View Post
    Thank you for your help so far.

    I inherited the site and am still learning Joomla, so will have to look at upgrading and do a bit of homework.

    I have had a quick look at blocking the attempts to login and it appears to be an extention option, rather than an inbuilt one, is that right?
    This is nothing to do with Joomla. I assume your on a cpanel server. You would login to Cpanel for your site and set a password for the joomla administrator directory. This creates a .htaccss file in that directory which asks for a password as soon as you try to access http:yoursite/administrator/

  8. #8
    callmeroy1's Avatar
    Join Date
    Mar 2012
    Location
    Walton, Surrey
    Posts
    7
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have found a readmorelink.php file that had the following code...

    // Get the article URL from $article->readmorelink not is a good idea
    // Jooma 1.5 don't generate value for readmore_link for some situations
    // like the frontpage
    // Thanks to Goran Stetic for discover this bug.

    //$route=$article->readmore_link;

    $route=JRoute::_(ContentHelperRoute::getArticleRou te($article->slug, $article->catslug, $article->sectionid));
    $link="<a href=\"$route\" class=\"readmorelink\">";

    $article->text=str_ireplace('{readmorelink}', $link, $article->text);
    $article->text=str_ireplace('{/readmorelink}', '</a>', $article->text);
    }
    else {
    $article->text=preg_replace('#{readmorelink}(.*?){/readmorelink}#s', '', $article->text);
    $article->text=str_ireplace('{readmorelink}', '', $article->text);
    $article->text=str_ireplace('{/readmorelink}', '', $article->text);
    }


    But I dont know enough about code to know if this is the problem or how to fix it.

    The readmore link works on everything other than the frontpage.

  9. #9

    Join Date
    Jun 2010
    Posts
    198
    Thank Post
    9
    Thanked 25 Times in 24 Posts
    Rep Power
    21
    Quote Originally Posted by callmeroy1 View Post
    I have found a readmorelink.php file that had the following code...

    // Get the article URL from $article->readmorelink not is a good idea
    // Jooma 1.5 don't generate value for readmore_link for some situations
    // like the frontpage
    // Thanks to Goran Stetic for discover this bug.

    //$route=$article->readmore_link;

    $route=JRoute::_(ContentHelperRoute::getArticleRou te($article->slug, $article->catslug, $article->sectionid));
    $link="<a href=\"$route\" class=\"readmorelink\">";

    $article->text=str_ireplace('{readmorelink}', $link, $article->text);
    $article->text=str_ireplace('{/readmorelink}', '</a>', $article->text);
    }
    else {
    $article->text=preg_replace('#{readmorelink}(.*?){/readmorelink}#s', '', $article->text);
    $article->text=str_ireplace('{readmorelink}', '', $article->text);
    $article->text=str_ireplace('{/readmorelink}', '', $article->text);
    }


    But I dont know enough about code to know if this is the problem or how to fix it.

    The readmore link works on everything other than the frontpage.

    Did you try the suggestion below I made earlier in the thread

    It sounds as though when you created the link you may have selected an option to open in a new window. Delete the link and create a new one, that may solve your problem.
    Try it and see what happens.

    Kili

SHARE:
+ Post New Thread

Similar Threads

  1. Default gateway settings etc. help please.
    By tickmike in forum Wireless Networks
    Replies: 21
    Last Post: 17th September 2006, 03:44 PM
  2. More Help Please With A Server.
    By tickmike in forum Windows
    Replies: 22
    Last Post: 5th September 2006, 02:59 AM
  3. Replies: 5
    Last Post: 4th July 2006, 05:39 PM
  4. questionaire linked to database help please!!!!!!!!!!!!!!!!!
    By suesmate in forum Educational Software
    Replies: 8
    Last Post: 3rd May 2006, 06:07 PM
  5. E Learning Credits - Help Please
    By MuppetQueen in forum Budgets and Expenditure
    Replies: 4
    Last Post: 12th December 2005, 03:10 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •