+ Post New Thread
Results 1 to 11 of 11
EduGeek Joomla 1.0 Package Thread, 500 Internal Server Error? in Projects:; I know I need to change my site to 1.5 but at the minute it's going to have to stay ...
  1. #1

    Join Date
    Jul 2008
    Posts
    26
    Thank Post
    3
    Thanked 1 Time in 1 Post
    Rep Power
    0

    500 Internal Server Error?

    I know I need to change my site to 1.5 but at the minute it's going to have to stay with 1.0 until I find the time to swap it. I'm having a problem where the server keeps timing out. This is happening at least once a day. It's our school website and doesn't look good to the parents. It's also very slow at loading when it does actually load. The error I get is below. Can anyone help? Thank you!


    500 Internal Server Error
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, *email address* and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

  2. #2
    Messa's Avatar
    Join Date
    Dec 2006
    Location
    Wolverhampton
    Posts
    301
    Thank Post
    67
    Thanked 29 Times in 25 Posts
    Rep Power
    22
    Usually this is to do with either incorrect permissions or using php_ in .htaccess.

    Is suPHP installed on the server?

  3. #3

    Join Date
    Jul 2008
    Posts
    26
    Thank Post
    3
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Hello, at the minute my hosting company are saying that the server my current database is on is overloaded and is causing a lot of problems. They've sent me details on how to transfer to a new database, which is causing me a headache. But hopefully this will solve my problem...

    The 500 error only comes up every so often, do you think it's more likely to be a server problem rather than an htaccess problem like you suggest? I'm willing to look at htaccess but don't want to start messing about with it if its ok. The site didn't have any problems until about 3 months ago.

  4. #4

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,452
    Thank Post
    408
    Thanked 671 Times in 613 Posts
    Rep Power
    192
    What problems are you having with the database move?

  5. #5
    mossj's Avatar
    Join Date
    Dec 2008
    Location
    Leicester
    Posts
    1,466
    Thank Post
    157
    Thanked 189 Times in 174 Posts
    Rep Power
    53
    Could you pm the address of the site? I have a suspician i would like to test before I make a big noise over it.

  6. #6

    Join Date
    Jul 2008
    Posts
    26
    Thank Post
    3
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Edu-IT, my problem is that I don't seem to be able to make a connection using the SSH. I'm on a mac with snow leopard and I'm not sure if this is causing the problem, but it just won't connect. Mossj, I'll pm you now, thank you!

  7. #7

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,078
    Thank Post
    160
    Thanked 940 Times in 732 Posts
    Blog Entries
    3
    Rep Power
    275
    The operating system should not be a problem, you should be able to ssh on to weather your using snow leopard or a windows os.

    another PM on way lol

    James.

  8. Thanks to EduTech from:

    tea_and_toast (27th September 2009)

  9. #8

    Join Date
    Jul 2008
    Posts
    26
    Thank Post
    3
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Thanks so much everyone for the help! I'm waiting for my hosting company to get back to me now as there seems to be a problem with the ssh details they've given me. EduTech has been a great help trying to figure out the problem so far. I'll let you know how I get on, thanks again!

  10. #9

    Join Date
    Jul 2008
    Posts
    26
    Thank Post
    3
    Thanked 1 Time in 1 Post
    Rep Power
    0
    It appears most of the problem here was caused by the hosting company... not me, thankfully. I've managed to import my database to the new server and it seems to be functioning fine. My only (and hopefully last!) question is: I have changed the database details within administrator to reflect the new database (ie: changed the host ip address, username etc) but the changes I have made subsequently are not reflected on the site. Will it just take a while for the new database to become associated with the site? Or should I be doing something else?

  11. #10

    Join Date
    Jul 2008
    Posts
    26
    Thank Post
    3
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Please ignore my last post... it seems the site and database just needed half an hour to find each other! All working now, phew! Thanks once again to Edu-Tech for his great help through PMs.

  12. #11

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,078
    Thank Post
    160
    Thanked 940 Times in 732 Posts
    Blog Entries
    3
    Rep Power
    275
    It's been a Pleasure Hopefully you wont have to do that again in a hurry.

    have a great evening, put your feet up and have a rest hehe

    James.

  13. Thanks to EduTech from:

    tea_and_toast (28th September 2009)



SHARE:
+ Post New Thread

Similar Threads

  1. Fireworks 8 internal error
    By PEO in forum Windows
    Replies: 11
    Last Post: 5th September 2009, 08:14 PM
  2. MRBS, PHP, IIS 6.0, and one 500 error
    By mossj in forum Web Development
    Replies: 7
    Last Post: 14th July 2009, 05:23 PM
  3. Ghost - Internal Error 19215
    By _Bat_ in forum Wireless Networks
    Replies: 5
    Last Post: 22nd May 2008, 11:20 AM
  4. 500 internal server error
    By sayf00 in forum EduGeek Joomla 1.0 Package
    Replies: 5
    Last Post: 16th February 2008, 02:47 PM
  5. Windows internal control error
    By witch in forum Windows
    Replies: 0
    Last Post: 15th June 2007, 09:25 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •