+ Post New Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 44
EduGeek Joomla 1.0 Package Thread, Optimise PHP & Apache Configuration in Projects:; Hi Some of you may know my Edugeek Joomla site is running slow. Someone suggested it could be the PHP ...
  1. #1

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468

    Optimise PHP & Apache Configuration

    Hi

    Some of you may know my Edugeek Joomla site is running slow. Someone suggested it could be the PHP configuration. I have attached out PHP.ini file, what changes can i make so speed my site up please? The site url is:
    Thanks

    Z

    Edit: please see below for apache config
    Last edited by FN-GM; 22nd August 2008 at 10:19 PM.

  2. #2
    Jona's Avatar
    Join Date
    May 2007
    Location
    Cranleigh
    Posts
    471
    Thank Post
    14
    Thanked 51 Times in 49 Posts
    Rep Power
    24
    Maybe install some caching - both APC and eaccelerator have commented sections in your config so might already be installed, worth having a read up and turning one of them on.

    You could turn off some of your php extentions if your not using them. Apart from that nothing that should especially affect performance.

    You could turn on gzip compression in apache for your images, etc.

    Cheers
    Jona
    Last edited by Jona; 11th July 2008 at 06:37 PM. Reason: correction

  3. Thanks to Jona from:

    FN-GM (11th July 2008)

  4. #3
    KarlGoddard's Avatar
    Join Date
    Jul 2005
    Location
    Bolton, Lancashire
    Posts
    272
    Thank Post
    37
    Thanked 18 Times in 18 Posts
    Rep Power
    26

  5. Thanks to KarlGoddard from:

    FN-GM (11th July 2008)

  6. #4

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Quote Originally Posted by Jona View Post
    Maybe install some caching - both APC and eaccelerator have commented sections in your config so might already be installed, worth having a read up and turning one of them off.

    You could turn off some of your php extentions if your not using them. Apart from that nothing that should especially affect performance.

    You could turn on gzip compression in apache for your images, etc.

    Cheers
    Jona
    Hi

    most of that means nothing to me

    as for the images, it downloads them fast once its started. It seems to be the initial reading of the php file.

    Quote Originally Posted by kgcs View Post
    Thanks i will have a look through that.

  7. #5
    Jona's Avatar
    Join Date
    May 2007
    Location
    Cranleigh
    Posts
    471
    Thank Post
    14
    Thanked 51 Times in 49 Posts
    Rep Power
    24
    Caching -
    See: eAccelerator - Trac
    To enable it (if it's installed) uncomment this block in your php.ini
    PHP Code:
    [eAccelerator]
    ;
    extension=eaccelerator.dll
    ;eaccelerator.shm_size "0"
    ;eaccelerator.cache_dir "C:\xampp\tmp"
    ;eaccelerator.enable "1"
    ;eaccelerator.optimizer "0"
    ;eaccelerator.debug "0"
    ;eaccelerator.check_mtime "1"
    ;eaccelerator.filter ""
    ;eaccelerator.shm_max "0"
    ;eaccelerator.shm_ttl "0"
    ;eaccelerator.shm_prune_period "0"
    ;eaccelerator.shm_only "0"
    ;eaccelerator.compress "1"
    ;eaccelerator.compress_level "9"
    ;eaccelerator.keys "shm_and_disk"
    ;eaccelerator.sessions "shm_and_disk"
    ;eaccelerator.content "shm_and_disk"
    ;eaccelerator.admin.name =
    ;
    eaccelerator.admin.password 
    Additionally you should be able to comment some of the extentions in the [Extentions] block of your php.ini that your not using an example is:
    extension=php_mssql.dll which if your not using a ms-sql database you can turn off. But this shouldn't have that much affect. I'm still slightly at a loose to know why your install is so slow are you sure it's php? Does the php load fast locally?

    Jona

  8. Thanks to Jona from:

    FN-GM (11th July 2008)

  9. #6

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    What do you do about username and password?

    also is it installed with xampp by default?

    thanks

  10. #7

    ZeroHour's Avatar
    Join Date
    Dec 2005
    Location
    Edinburgh, Scotland
    Posts
    5,837
    Thank Post
    974
    Thanked 1,406 Times in 851 Posts
    Blog Entries
    1
    Rep Power
    460
    We use Xcache here and it gets very good write ups.

  11. #8
    Jona's Avatar
    Join Date
    May 2007
    Location
    Cranleigh
    Posts
    471
    Thank Post
    14
    Thanked 51 Times in 49 Posts
    Rep Power
    24
    Quote Originally Posted by ZeroHour View Post
    We use Xcache here and it gets very good write ups.
    Yeh me too ZH but Xcache dosn't get installed with xampp but the looks of it eAcclerator and APC do.

  12. #9
    Jona's Avatar
    Join Date
    May 2007
    Location
    Cranleigh
    Posts
    471
    Thank Post
    14
    Thanked 51 Times in 49 Posts
    Rep Power
    24
    Quote Originally Posted by FN-Greatermanchester View Post
    What do you do about username and password?

    also is it installed with xampp by default?

    thanks
    I *think* the username and password only matter if you want to use the cache administration console wigget so just set them to what ever I think. I assume it is installed by default but I'm not sure because I use a WAMP stack built from scratch.

  13. #10

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Quote Originally Posted by Jona View Post
    Caching -
    See: eAccelerator - Trac
    To enable it (if it's installed) uncomment this block in your php.ini
    PHP Code:
    [eAccelerator]
    ;
    extension=eaccelerator.dll
    ;eaccelerator.shm_size "0"
    ;eaccelerator.cache_dir "C:\xampp\tmp"
    ;eaccelerator.enable "1"
    ;eaccelerator.optimizer "0"
    ;eaccelerator.debug "0"
    ;eaccelerator.check_mtime "1"
    ;eaccelerator.filter ""
    ;eaccelerator.shm_max "0"
    ;eaccelerator.shm_ttl "0"
    ;eaccelerator.shm_prune_period "0"
    ;eaccelerator.shm_only "0"
    ;eaccelerator.compress "1"
    ;eaccelerator.compress_level "9"
    ;eaccelerator.keys "shm_and_disk"
    ;eaccelerator.sessions "shm_and_disk"
    ;eaccelerator.content "shm_and_disk"
    ;eaccelerator.admin.name =
    ;
    eaccelerator.admin.password 
    Additionally you should be able to comment some of the extentions in the [Extentions] block of your php.ini that your not using an example is:
    extension=php_mssql.dll which if your not using a ms-sql database you can turn off. But this shouldn't have that much affect. I'm still slightly at a loose to know why your install is so slow are you sure it's php? Does the php load fast locally?

    Jona

    Just done this rebooted the server and no change.

  14. #11

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,087
    Thank Post
    210
    Thanked 432 Times in 312 Posts
    Rep Power
    146
    Are you sure it's PHP execution time holding up proceedings? It seems like it may be something else to me, as when I've viewed your site once each subsequent refresh is very fast, but it would be re-generating the page each time I press refresh, so if it were a PHP problem I'd expect it to take ages every time.

    I would possibly look at your apache configuration, and how the server is configured, as it could be the webserver delaying things, and not PHP.

    Just out of interest if you load the page on the server itself after clearing your cache, is it the same speed as viewing it externally??

    Mike.

    Edit: you might like to try inserting some code in your template to time PHP execution.

    Back up your template first of course!

    Then put this at the top of the main template PHP code.

    $time_start = microtime(true);

    <<<<Rest of template code here>>>

    Put this at the end after everything else (inside the PHP identifier of course)

    $time_end = microtime(true);
    $time = $time_end - $time_start;
    echo "Page generated in $time seconds\n";

    It should give you a time that PHP took to generate the page right at the bottom of every page. I would have used the code boxes, but they seem to have disappeared!

    Mike.
    Last edited by maniac; 11th July 2008 at 08:18 PM.

  15. #12
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,505
    Thank Post
    10
    Thanked 508 Times in 445 Posts
    Rep Power
    116
    I did post on the other thread but it got eaten by farsehosts.

    If the speed is ok locally and on the same network then it's not a php issue. You say it's on another network. You aren't using ISA to publish the server are you as that has been unbelievebally awful when I used it with a php site in the past, often it would just halt on images.

  16. #13

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Just out of interest if you load the page on the server itself after clearing your cache, is it the same speed as viewing it externally??
    Its very fast when i got to htpp://localhost on the Server.

    i have attached to apache config, please help

    Quote Originally Posted by DMcCoy View Post
    I did post on the other thread but it got eaten by farsehosts.

    If the speed is ok locally and on the same network then it's not a php issue. You say it's on another network. You aren't using ISA to publish the server are you as that has been unbelievebally awful when I used it with a php site in the past, often it would just halt on images.
    To be honest i am not 100% but i don’t think it is, i don’t handle that side. We are on a network with our local CLC and the guy there looks after the DMZ. The webserver has been put directly exposed to the internet in front of all the firewalls etc and the same thing happens.
    Attached Files Attached Files
    Last edited by FN-GM; 11th July 2008 at 08:23 PM.

  17. #14
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,505
    Thank Post
    10
    Thanked 508 Times in 445 Posts
    Rep Power
    116
    ServerName localhost:80

    You could try changing this to the servers IP that may help.

  18. #15

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Quote Originally Posted by DMcCoy View Post
    ServerName localhost:80

    You could try changing this to the servers IP that may help.
    Tried that. I tried using the public and the local server IP and i get the same result. I put it back to default after i played with it.



SHARE:
+ Post New Thread
Page 1 of 3 123 LastLast

Similar Threads

  1. Apache 2.2 configuration
    By saundersmatt in forum Web Development
    Replies: 3
    Last Post: 12th July 2008, 10:17 AM
  2. Sophos configuration
    By Bobo in forum Windows
    Replies: 4
    Last Post: 27th June 2008, 11:52 AM
  3. VLAN Configuration
    By robknowles in forum Wireless Networks
    Replies: 1
    Last Post: 28th May 2008, 05:01 AM
  4. Office configuration
    By mseaney in forum Windows
    Replies: 6
    Last Post: 1st December 2005, 01:38 PM
  5. Scripting IP configuration.
    By Dos_Box in forum Scripts
    Replies: 3
    Last Post: 2nd September 2005, 10:07 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •