Our children use i-Progress for homework and seemingly benign "tests". i-Progress, in turn, likes to use Adobe Shockwave, a group of people only joined by the Aztecs.

Shockwave is updated to the latest version on all workstations, yet EVERY time a child goes to i-Progress in school, it refuses to recognise it and wants to install it.

Is it demanding an older version or something? If it is, why on Earth??

Many thanks in advance...