Does anybody use Pinnacle Studio?

We have version 12 and have been having an ongoing issue for quite some time which we have been unable to resolve. It is a random fault where a blue exclamation mark is displayed instead of all the transitions, video clips, text etc. This happens for students, but it is entirely random. They could try the computer next to them (which is identical) and it will work whereas the next one along may not work! Try again the next day and the one that was not working now is ... (and you can see how this goes on!)

We have tried:
- rebuilding machines,
- removing various bits if software to test for conflicts,
- latest updates,
- changing permissions
- tried different computers

We have also recently taken delivery of some brand new Core i5 workstations with upgraded graphics cards, 4GB RAM and still the same issue - so its not machine spec's.

The teachers laptops are not having this issue (as far as we are aware!) - just the student curriculum workstations.

Any ideas would be greatly received!