+ Post New Thread
Results 1 to 8 of 8
Educational Software Thread, TTS DataDisc Pt network install in Technical; Hi All Having major issues getting this software to run from a network location. I have installed the software using ...
  1. #1


    Join Date
    Sep 2009
    Posts
    565
    Thank Post
    13
    Thanked 55 Times in 34 Posts
    Rep Power
    223

    TTS DataDisc Pt network install

    Hi All

    Having major issues getting this software to run from a network location. I have installed the software using the Network option on the CD and then inserted the key.

    When running the Software I get the following error:

    Could not load frmMain (339)

    I noticed that the program requires some shared files to be on the Local Hard Drive and some registry keys to be imported for it to run so to achieve this I have cobbled together the following batch file to launch the software:

    @echo off
    regedit /s n:\DataLogger\tts.reg
    XCOPY N:\DataLogger\Shared "c:\Program Files\Abington\Shared" /Y /I /Q
    regsvr32 /s "c:\Program Files\Abington\Shared\Abdat.ocx"
    regsvr32 /s "c:\Program Files\Abington\Shared\abUseful2.ocx"
    regsvr32 /s "c:\Program Files\Abington\Shared\oik32.ocx"
    regsvr32 /s "c:\Program Files\Abington\Shared\AbWMI.dll"
    cls
    echo Launching DataDisc Explore
    echo Please Wait
    echo.
    echo.
    echo This window will close when you
    echo quit the DataDisc Application
    N:\DataLogger\DatadiscPt.exe explore

    This has solved some of the problems but I still get the above error. Does anyone have any ideas?

    Cheers

  2. #2
    jamesreedersmith's Avatar
    Join Date
    Sep 2009
    Location
    Ruskington
    Posts
    1,153
    Thank Post
    78
    Thanked 253 Times in 227 Posts
    Rep Power
    76
    Did this ever get fixed?

  3. #3


    Join Date
    Sep 2009
    Posts
    565
    Thank Post
    13
    Thanked 55 Times in 34 Posts
    Rep Power
    223
    If i'm honest, i can't remember. I work at various schools and i'm back there on Monday morning so i will take a look at it then.

  4. #4


    Join Date
    Sep 2009
    Posts
    565
    Thank Post
    13
    Thanked 55 Times in 34 Posts
    Rep Power
    223
    Sorry for the double post, Still having this issue.

    Tried to package the software into a portable exe with no joy too.

    Spoke to TTS and they are going to get back to me.

  5. #5
    RTi
    RTi is offline

    Join Date
    Feb 2008
    Location
    Birmingham
    Posts
    153
    Thank Post
    23
    Thanked 15 Times in 10 Posts
    Rep Power
    16
    I also think you will need to install the drivers locally on each PC .. everytime I plugged the USB>Serial cable in a new PC .. it asked for drivers..

  6. #6
    TomTomGo's Avatar
    Join Date
    Jan 2010
    Location
    Preston, Lancashire
    Posts
    32
    Thank Post
    20
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by LeightonJames View Post
    When running the Software I get the following error:

    Could not load frmMain (339)
    Sorry to dig up an old thread but I'm having this issue on local installs. Spoke to TTS and they suggested installing Microsoft Office to rectify the issue. I've installed Office 2010 32-Bit Pro Plus, without entering a key and this has resolved the error!! TTS couldn't tell me which individual component of Office fixes the issue, so ive had to install the entire suite on machines that just need Office 2010 Starter on them. Talk about using a sledghammer to crack a walnut!

    Does anyone have a simpler/neater solution?

  7. #7
    chazzy2501's Avatar
    Join Date
    Jan 2008
    Location
    South West
    Posts
    1,781
    Thank Post
    213
    Thanked 263 Times in 213 Posts
    Rep Power
    67
    you may also notice that the latest (windows 7 compatible version) has a built in 30 second delay on load! It's such a pain. I found my ollld version that was on the CD for my XP clients and used that. I've not been able to WinstallLE it either had to manually install it onto every science laptop.

  8. #8

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,211 Times in 761 Posts
    Rep Power
    394
    At a guess I would say it's probably some of the VBA components, most likely the common controls library.

    Try downloading this file: http://activex.microsoft.com/controls/vb6/mscomct2.cab and extract it anywhere, then right-click on the inf file and select 'Install'.

SHARE:
+ Post New Thread

Similar Threads

  1. TTS Easi-View problems
    By sparkeh in forum AV and Multimedia Related
    Replies: 6
    Last Post: 26th January 2012, 12:41 PM
  2. TTS Easi-View MSI installation
    By mhundley in forum Educational Software
    Replies: 7
    Last Post: 12th January 2012, 01:56 PM
  3. Well Done TTS - Easi-Speak Pro Issue
    By SYSMAN_MK in forum Hardware
    Replies: 5
    Last Post: 1st July 2010, 03:34 PM
  4. Science Scope Datadisc PT
    By atfnet in forum Educational Software
    Replies: 2
    Last Post: 17th December 2008, 10:39 AM
  5. Network vs Local Install
    By in forum How do you do....it?
    Replies: 2
    Last Post: 9th May 2006, 09:05 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •