+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 17
Educational Software Thread, Activstudio PE 2.5.101 in Technical; We have paid promethean for a update to our activstudio software, as we are starting our XP upgrade on the ...
  1. #1
    robk's Avatar
    Join Date
    Nov 2005
    Location
    Ashbourne
    Posts
    759
    Thank Post
    175
    Thanked 130 Times in 109 Posts
    Blog Entries
    1
    Rep Power
    48

    Activstudio PE 2.5.101

    We have paid promethean for a update to our activstudio software, as we are starting our XP upgrade on the 3rd, and want to roll out activstudio via AD.

    Athough the cd contains MSI`s they are installshield versions that the ISSETUPDRIVEN=1 trick does not seem to work.

    Has anyone got a procedure I can try? I am guessing promethean tech support will be closed for the festive season!

    Any suggestions would be greatly recieved.

    Rob Keeling

  2. #2
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    34

    Re: Activstudio PE 2.5.101

    Have you deployed the right ISSCRIPT.MSI to PCs?

    EDIT: Also, googling for 'ISSETUPDRIVEN' produces a few useful looking hits.

  3. #3

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,599
    Thank Post
    109
    Thanked 766 Times in 597 Posts
    Rep Power
    181

    Re: Activstudio PE 2.5.101

    If push comes to shove you can always use the Windows Installer Wrapper Wizard.... not ideal but it is very effective.

  4. #4
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    34

    Re: Activstudio PE 2.5.101

    Don't think wrapping an MSI based install inside a WIWW MSI will work.

  5. #5

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,599
    Thank Post
    109
    Thanked 766 Times in 597 Posts
    Rep Power
    181

    Re: Activstudio PE 2.5.101

    @ajbritton: Why not? If you wrap the installshield bit you should not have a problem.

  6. #6
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    34

    Re: Activstudio PE 2.5.101

    All I know is that when I wrapped the SIMS Infrastructure Setup (which is an InstallShield installer), the .NET 1.1 runtime fails to install. An error appears in a MSI log for the .NET install which said something about another installation already being active. I believe it is necessary to use a particular type of custom action to install 'nested' MSIs, and WIWW does not do this. My guess is that the Windows Installer service can only cope with one active installation at a time, and the special custom actions suspend the active installation session until the nested installation completes or fails.

  7. #7
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    34

    Re: Activstudio PE 2.5.101

    Having said all that, I note the following use of WIWW to effectively 'nest' the installation of ISSCRIPT.MSI on AppDeploy.

    Now I'm confused. :?

  8. #8

    john's Avatar
    Join Date
    Sep 2005
    Location
    London
    Posts
    10,619
    Thank Post
    1,499
    Thanked 1,053 Times in 922 Posts
    Rep Power
    304

    Re: Activstudio PE 2.5.101

    Didn't Dan Turner say they had an MSI version avalable now?

  9. #9
    robk's Avatar
    Join Date
    Nov 2005
    Location
    Ashbourne
    Posts
    759
    Thank Post
    175
    Thanked 130 Times in 109 Posts
    Blog Entries
    1
    Rep Power
    48

    Re: Activstudio PE 2.5.101

    Quote Originally Posted by ajbritton
    Have you deployed the right ISSCRIPT.MSI to PCs?

    EDIT: Also, googling for 'ISSETUPDRIVEN' produces a few useful looking hits.
    Yep, isscript9 deployed, I can`t even get the msi to start installing.

    Appdeploy says use the msi from the cd, I thought promethean had fixed the problem!

    Rob Keeling

  10. #10
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    34

    Re: Activstudio PE 2.5.101

    Are you getting the 'must be run from SETUP.EXE' message? Try looking here. There is something in section 2 of the Discussion about modifying the OnCheckSilentInstall CA.

  11. #11
    robk's Avatar
    Join Date
    Nov 2005
    Location
    Ashbourne
    Posts
    759
    Thank Post
    175
    Thanked 130 Times in 109 Posts
    Blog Entries
    1
    Rep Power
    48

    Re: Activstudio PE 2.5.101

    Quote Originally Posted by ajbritton
    Are you getting the 'must be run from SETUP.EXE' message? Try looking here. There is something in section 2 of the Discussion about modifying the OnCheckSilentInstall CA.
    Yes, Tried that, still no luck. Has anyone else been able to deploy this package?

    Thanks

    Rob Keeling

  12. #12
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    34

    Re: Activstudio PE 2.5.101

    More info on MSI nesting

    According to this, it is not possible to run two installations in the same process. If this is attempted, a 'ERROR_INSTALL_ALREADY_RUNNING' error is generated. IIRC, this is what I was seeing when trying to install SIMS Infrastructure using WIWW.

    It IS possible to nest MSIs as shown here. According to this, it is necessary to use special Custom Actions.

  13. #13
    robk's Avatar
    Join Date
    Nov 2005
    Location
    Ashbourne
    Posts
    759
    Thank Post
    175
    Thanked 130 Times in 109 Posts
    Blog Entries
    1
    Rep Power
    48

    Re: Activstudio PE 2.5.101

    Bit of an update!

    After many hour fiddling with vmware over christmas.....

    The new Activboard driver installs as a stright MSI.

    Activboard Student edition will install from a MSI after running Setup /a, then
    applying a ISSETUPDRIVEN=1 transform and ensuring isscript9.msi is installed.

    We had to edit a copy of iscript9.msi to change the guid as iscript8.msi was already deployed....... This was the sticking point.

    Apparently there is a MSI version of the main software but it has to be requested from a contact within promethean. I am waiting for an email back on that.

    Thought I ought to update the thread in case it helps others. Thanks to everyone for the suggestions.

    Rob Keeling

  14. #14

    john's Avatar
    Join Date
    Sep 2005
    Location
    London
    Posts
    10,619
    Thank Post
    1,499
    Thanked 1,053 Times in 922 Posts
    Rep Power
    304

    Re: Activstudio PE 2.5.101

    pehaps a PM to Dan Turner on here (drjturner) will be helpful rob as he is from Promethean

  15. #15
    Zoom7000's Avatar
    Join Date
    Feb 2006
    Location
    London
    Posts
    955
    Thank Post
    308
    Thanked 86 Times in 57 Posts
    Rep Power
    33

    Re: Activstudio PE 2.5.101

    I have managed to get the none MSI version installing FULLY silently. I would love to help you, however, I am currently at home recovering from a very painful back. I will have a look through my USB Flash Drives and see if I have the instructions and batch scripts.

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. ActivStudio V3 Network install
    By bishopsgarthstockton in forum Educational Software
    Replies: 34
    Last Post: 4th June 2009, 11:23 AM
  2. Using Activstudio / Primary on a Smartboard
    By Smonach in forum Educational Software
    Replies: 3
    Last Post: 4th May 2007, 09:13 AM
  3. Activote and ActivStudio software
    By gwendes in forum Educational Software
    Replies: 2
    Last Post: 2nd May 2007, 03:30 PM
  4. Activstudio 2.5 PE
    By Ste_Harve in forum Educational Software
    Replies: 0
    Last Post: 1st December 2006, 11:40 AM
  5. ActivStudio 2 PE
    By dezt in forum Educational Software
    Replies: 16
    Last Post: 6th November 2006, 12:16 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •