+ Post New Thread
Results 1 to 4 of 4
Educational Software Thread, exo phphelpdesk in Technical; Hi Please can someone help me. I have installed exo php helpdesk on one of my linux boxs and its ...
  1. #1
    ricki's Avatar
    Join Date
    Jul 2005
    Location
    uk
    Posts
    1,475
    Thank Post
    20
    Thanked 164 Times in 157 Posts
    Rep Power
    52

    exo phphelpdesk

    Hi

    Please can someone help me. I have installed exo php helpdesk on one of my linux boxs and its working great but I have a problem with registing new users. When you try and enter a persons e-mail it says

    The email address you specified was not in a valid known format

    We have an e-mail adresses like user@balshaws.lancs.sch.uk.

    It will accept user@isp.com.

    Please can someone have a look at the php code and advice me how I can remove the validation for the e-mail.

    In the attached zip file is the orginal program that I downloaded from the site. I have e-mailed the support for the site but they do not come back.

    Thanks for all your help,

    Richard Boocock
    Attached Files Attached Files

  2. #2
    wesleyw's Avatar
    Join Date
    Dec 2005
    Location
    Kingswinford
    Posts
    2,208
    Thank Post
    225
    Thanked 50 Times in 44 Posts
    Blog Entries
    1
    Rep Power
    30
    Looks like it comes from the conf.php file and validates against a function preg_match. I'll keep digging.

    Interestingly it doesn't bring up the same error when installing the system I'll have to keep checking.



    Wes
    Last edited by wesleyw; 21st January 2008 at 02:32 PM.

  3. #3
    ricki's Avatar
    Join Date
    Jul 2005
    Location
    uk
    Posts
    1,475
    Thank Post
    20
    Thanked 164 Times in 157 Posts
    Rep Power
    52

    Smile

    Thanks any help you can give I would be grateful.

    Richard

  4. #4
    White_Fi's Avatar
    Join Date
    Sep 2008
    Location
    Ipswich
    Posts
    185
    Thank Post
    7
    Thanked 34 Times in 32 Posts
    Rep Power
    33
    **NOTE** To anyone using phpexo desk,

    The default code is very vulnerable to SQLInjection attacks!

    Recommend strongly not to use it or check the code and sanitise it yourself correctly.
    Stuart White
    Network Security Analyst
    Specialists in Internet Security and Connectivity

    Tel: 01473 281211

SHARE:
+ Post New Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •