+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16
Educational Software Thread, PTC Creo in Technical; DT are looking at using PTC Creo next year following one of them going on a course and I've just ...
  1. #1

    Join Date
    May 2008
    Location
    Kent
    Posts
    601
    Thank Post
    29
    Thanked 80 Times in 69 Posts
    Rep Power
    30

    PTC Creo

    DT are looking at using PTC Creo next year following one of them going on a course and I've just been sent the install instructions and i'm slightly worried. Is anyone using this or found a method of deploying this silently?

  2. #2

    Join Date
    Jul 2009
    Posts
    304
    Thank Post
    8
    Thanked 47 Times in 40 Posts
    Rep Power
    17
    Sorry what version?

    If youíre just installing the Creo 2.0 Student edition, you canít use a license server. You would need to request the full Academic version for that. The Student edition uses a common product code that you can use on every computer
    Last edited by andydis; 5th June 2014 at 04:26 PM.

  3. #3

    Join Date
    May 2008
    Location
    Kent
    Posts
    601
    Thank Post
    29
    Thanked 80 Times in 69 Posts
    Rep Power
    30
    I am awaiting access to the full academic version but reading through the instructions that have been sent across you've got to spend 10 minutes at each machine faffing to get it setup and give users permission to run scripts.
    Love the instructions for the student edition stipulate at the top "Note: Before starting the installation process please turn off your antivirus software as it could prevent the installation of some libraries." If I have to do this with each station on the network I will be advising they find an alternative.

    I've emailed asking if its possible to perform an unattended install but I'm not holding my breath.

  4. #4

    Join Date
    Oct 2013
    Posts
    45
    Thank Post
    7
    Thanked 4 Times in 4 Posts
    Rep Power
    3
    @talwood_6 I've just installed Creo 2.0 Academic Version in the holiday on 31 machines. It took me about 5-7 minutes in total on each machine setting it up. You don't need to turn off the AV to install it as I have installed it with the AV on and its fine. There were some problems with the software like it was displaying some of the teachers machine and some servers in "Network neighbourhood" and when I started to run the software it was reporting an error with the software but manage to fix these.

  5. #5

    Join Date
    May 2008
    Location
    Kent
    Posts
    601
    Thank Post
    29
    Thanked 80 Times in 69 Posts
    Rep Power
    30
    Quote Originally Posted by Matty94 View Post
    @talwood_6 I've just installed Creo 2.0 Academic Version in the holiday on 31 machines. It took me about 5-7 minutes in total on each machine setting it up. You don't need to turn off the AV to install it as I have installed it with the AV on and its fine. There were some problems with the software like it was displaying some of the teachers machine and some servers in "Network neighbourhood" and when I started to run the software it was reporting an error with the software but manage to fix these.
    I've managed to package up the program so it installs and licences all the componets just need to test the uninstall script and package some of the plugins so they install after.
    PTC support have been less than useless but fortunately found a couple of guides by 3rd parties online.

  6. #6
    robjduk's Avatar
    Join Date
    Jun 2011
    Posts
    523
    Thank Post
    25
    Thanked 76 Times in 59 Posts
    Rep Power
    26
    We use Creo and have made an msi using Advanced Installer which talks back to the server. I remember it was a pain in the arse to do due to the size of the software so every mistake I had to revert and rerun the repackager. Anyway I seem to remember it took them ages to send the software through to me after my teacher sorted the course out.

  7. #7

    Join Date
    Oct 2013
    Posts
    45
    Thank Post
    7
    Thanked 4 Times in 4 Posts
    Rep Power
    3
    Quote Originally Posted by Tallwood_6 View Post
    I've managed to package up the program so it installs and licences all the componets just need to test the uninstall script and package some of the plugins so they install after.
    PTC support have been less than useless but fortunately found a couple of guides by 3rd parties online.
    PTC Support has been pretty good to me, fixed some of the issues I was having. If you go onto PTC community, they are more likely to help you out. I managed to get the full installation guide off them if you want that?

    What spec are your machines that are running Creo?

  8. #8

    Join Date
    May 2008
    Location
    Kent
    Posts
    601
    Thank Post
    29
    Thanked 80 Times in 69 Posts
    Rep Power
    30
    Quote Originally Posted by Matty94 View Post
    PTC Support has been pretty good to me, fixed some of the issues I was having. If you go onto PTC community, they are more likely to help you out. I managed to get the full installation guide off them if you want that?

    What spec are your machines that are running Creo?

    Will mostly be HP z400 workstations, I've managed to package everything up now just need to do some further testing and then I will post instructions for those interested. I did see the communities but thought I might get a response from the online academic support form or one of the emails I sent directly to support. If they gave me access to the knowledge base I'm sure there's some useful guides on there!

    Full install guide would be most handy though if you can share.

  9. #9

    Join Date
    Oct 2013
    Posts
    45
    Thank Post
    7
    Thanked 4 Times in 4 Posts
    Rep Power
    3
    That some nice machines you've got. How much RAM have you got installed? I was able to get in contact with one of their technicians after one of our teachers contacted their sales team about something. If you PM with your email, I'll be able to send the installation guide.

  10. Thanks to Matty94 from:

    Tallwood_6 (11th June 2014)

  11. #10

    Join Date
    May 2008
    Location
    Kent
    Posts
    601
    Thank Post
    29
    Thanked 80 Times in 69 Posts
    Rep Power
    30
    Quote Originally Posted by Matty94 View Post
    That some nice machines you've got. How much RAM have you got installed? I was able to get in contact with one of their technicians after one of our teachers contacted their sales team about something. If you PM with your email, I'll be able to send the installation guide.
    Purchased them all refurbished for technology for about £300 each a year ago, RDC - The World's foremost IT Disposal and IT Recycling Company they don't come with warranties but they are all MAR refurbished, they only have 8gb RAM but all come with NIVIDA quadro graphics cards that play nicely with the various CAD tech programs they use.

    For others looking to deploy this I following the guide posted here IT Pro Tips for PTC Creo 2 | ITNinja
    Note you need to package and deploy the Creo Agent, Thumbviewer & CreoView Express separately otherwise the users is prompted to install these at first launch but all 3 have .msi installers.

  12. #11

    Join Date
    Nov 2008
    Posts
    17
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi
    Has anyone managed to package this up on an RM CC4 network? PTC support have said that I have to manually copy the 3gb files to each machine and then run it manually as administrator on each machine to let it install the thumbviewer etc... As it needs to go out to over one hundred machines I do not wish to manually install it. Also where are the msi's for the Creo agent, thumb viewer and express? Thanks in advance for any help.
    carolyn

  13. #12

    Join Date
    May 2008
    Location
    Kent
    Posts
    601
    Thank Post
    29
    Thanked 80 Times in 69 Posts
    Rep Power
    30
    Yes we have it working on CC4 following the instructions I posted

  14. #13

    Join Date
    Nov 2008
    Posts
    17
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi
    Sorry I am being rather dim but which instructions? I had a look on the ninja link but I cannot understand any of those instructions and how they could be done in CC4. We also have no trace of M070 or M040 anything, the folder in our install is M010. Also where do I find the extra msi's they do not appear for us. I am really sorry but I have been messing with this for weeks and PTC have told me I just have to do it all manually on each machine. I am really confused. I know I do sound dim but I have hundreds of other pieces of software that I have installed perfectly happily. It is just this one that is beating me.

    Sorry :-(

  15. #14

    Join Date
    May 2008
    Location
    Kent
    Posts
    601
    Thank Post
    29
    Thanked 80 Times in 69 Posts
    Rep Power
    30
    PM your email address and I'll sort you out some packages have you got the licence server sorted a port set and exceptions in place on the server and station firewalls?

  16. #15

    Join Date
    Mar 2008
    Posts
    49
    Thank Post
    11
    Thanked 13 Times in 9 Posts
    Rep Power
    41
    PTC used to only release a site license for Creo once teachers had completed accredited training, does anyone know if this is still the case? I can't find reference to it on their website.



SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Pro Creo 2.0
    By mshill in forum Educational Software
    Replies: 7
    Last Post: 22nd May 2014, 01:19 PM
  2. CREO Elements Licence Server in a VM
    By fiza in forum Educational Software
    Replies: 2
    Last Post: 28th June 2012, 02:20 PM
  3. Creo Elements 5.0 Question
    By robjduk in forum Educational Software
    Replies: 1
    Last Post: 10th May 2012, 11:10 AM
  4. PTC Licensing Server
    By eddyc in forum Educational Software
    Replies: 0
    Last Post: 8th December 2011, 12:34 PM
  5. PTC Pro/Engineer Wildfire 4 License changing
    By Sean in forum Educational Software
    Replies: 0
    Last Post: 1st March 2010, 08:26 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •