+ Post New Thread
Results 1 to 6 of 6
Educational Software Thread, SuccessMaker Again ! (or SuccessMaker Migration 2 - VM trouble !) in Technical; As per my other thread in BTRD about annoying things you did today, I am seeing a massive issue at ...
  1. #1
    rich_tech's Avatar
    Join Date
    Mar 2011
    Location
    Wales
    Posts
    1,026
    Thank Post
    129
    Thanked 132 Times in 115 Posts
    Rep Power
    63

    SuccessMaker Again ! (or SuccessMaker Migration 2 - VM trouble !)

    As per my other thread in BTRD about annoying things you did today,

    I am seeing a massive issue at the moment with a successmaker migration on our site, I am going from a 2003 R2 server to a Hyper-V based Server 2008 R2 VM and am having major problems with getting the database started on the new VM and its this awful Sybase SQL stuff.

    I have followed the 1.7.2 SP1 instructions on the RM page to the letter on this new installation before transferring the database over, its a standalone server installation and so far I have seen pretty much everything listed on the RM page as a "Possible Issue" has happened as well on this server, in that content stuff wont install and the database refuses to start, despite me disabling and stopping the old DB and physically shutting that box down and working through all solutions featured.

    I have searched google and both the RM and Pearson support sites and have tried all the different trouble shooting for the problem today, the logging shows that its basically a permissions issue with the database directory that is stopping it from starting as the SYSTEM user cannot read or write in the SME\ResultsManager\SuccessMaker\database directory, this is despite me setting the permissions for SYSTEM absolutely everywhere with the share even on the specific directory in 2008 R2.

    Has anyone else come managed to get SuccessMaker working a 2008 R2 VM like this ? has anyone else ever had a problem with this folder not having permissions and overcome it ?

    I have even tried things not on the list here, like completely remaking the share, manually setting permissions on all the directories and even starting again from scratch to no avail so far.

  2. #2

    3s-gtech's Avatar
    Join Date
    Mar 2009
    Location
    Wales
    Posts
    2,711
    Thank Post
    144
    Thanked 548 Times in 492 Posts
    Rep Power
    149
    Question 1 - does it work on a 64 bit OS at all? I'd imagine it does, but is it possible to create a Server 2008 R1 x86 VM to try? Not tried it yet myself. Alternatively, it may just not run from Program Files (x86) on the 64 bit machine.

    I remember something similar on ours, but it's nearly five years since I last migrated ours (just checked the files) so my memory is hazy.

  3. Thanks to 3s-gtech from:

    rich_tech (12th March 2014)

  4. #3
    rich_tech's Avatar
    Join Date
    Mar 2011
    Location
    Wales
    Posts
    1,026
    Thank Post
    129
    Thanked 132 Times in 115 Posts
    Rep Power
    63
    Hello,

    According to RM and information I have gotten off their website, it is supposedly ok to run on a 2008 R2 Server (we use that generally for all our virtual servers) I am using their own standalone instructions to install it as well, though it seems to be losing the plot a bit with the SME share on the hard disk from what I can see in the successmaker logs on the machine when diagnosing the problem, it just cannot read/write to the Database directory, despite me adding the "System" user absolutely everywhere on the permissions of the main parent and the actual directory on the machine.

    I did not consider a standard 2008 server and can't see how that would be anyway massively different from the 2008 R2 aside from the program files bit, though I think I may possibly give this a try when I get back to work a week Monday, the annoying thing is as everyone knows, pretty much when you get the VM running and working, its sorted forever then pretty much.

    *frustrating*

  5. #4

    3s-gtech's Avatar
    Join Date
    Mar 2009
    Location
    Wales
    Posts
    2,711
    Thank Post
    144
    Thanked 548 Times in 492 Posts
    Rep Power
    149
    I seem to remember something about the permissions within the database itself, and needing to ensure that the same credentials are used on both instances (this was within the Sybase management console). I'm not sure if that's still the same, and RM's instructions should include all this.

    The only real difference with 2008 R1 was it was the last version of Windows Server to come in 32 bit form. If RM say that 2008 R2 works, then I'd use that as it's a better OS.

    Do you have any active RM support for this?

  6. Thanks to 3s-gtech from:

    rich_tech (12th March 2014)

  7. #5
    rich_tech's Avatar
    Join Date
    Mar 2011
    Location
    Wales
    Posts
    1,026
    Thank Post
    129
    Thanked 132 Times in 115 Posts
    Rep Power
    63
    After the break, I have revisited this and wanted to thank you for your help, I realised when I was sitting there looking at the RM document, that pretty much every issue which I had experienced had "2008 R2" next to it, so along with advice in the thread, I have decided to bite the bullet and created a normal 2008 server, which has worked like a charm so far in its creation.

    The only issue I have now is that, Ideally I would like to move the database off the old server onto the new one and wanted to know if anyone had experience of this ?

    Its that horrible Sybase database software they use so I am unsure about it, I have had a brief chat to RM about it yesterday when they rang on an off-chance wanting to speak to a colleague, the upshot of their "non-help" is that they want to send out an engineer to us at cost to do it as its not a product they actively support these days, especially as we are version 1.7.2 SP1, and it can be a bit "tricky" to move a database from one server to another according to their staff member.

    I don't want to pay for any engineer visit for something which is doable possibly by myself in-house, so if anyone has that experience and would not mind sharing, it would be great,

    Thanks,

    Rich

  8. #6
    rich_tech's Avatar
    Join Date
    Mar 2011
    Location
    Wales
    Posts
    1,026
    Thank Post
    129
    Thanked 132 Times in 115 Posts
    Rep Power
    63
    After completing its migration, I just wanted to follow it up with a Thanks to the thread and its participants,

    We now have a Windows Server 2008 VM running this server version 1.7.2 SP1 and it is going fine, No teething problems at all with plain 2008, I would say based on the experience with it, avoid 2008 R2 especially in a VM for this software, it caused major headaches when switching them over in that most of the stuff RM had as a possible issue happened and a lot of their "Cures" didn't work.

    I even managed to wangle out of RM an actual guide to getting the server over, after they tried to get an engineer booked in to "sort out a move" as it was "complicated and not straightforward" - It actually was very straightforward.

    - - - Updated - - -

    After completing its migration, I just wanted to follow it up with a Thanks to the thread and its participants,

    We now have a Windows Server 2008 VM running this server version 1.7.2 SP1 and it is going fine, No teething problems at all with plain 2008, I would say based on the experience with it, avoid 2008 R2 especially in a VM for this software, it caused major headaches when switching them over in that most of the stuff RM had as a possible issue happened and a lot of their "Cures" didn't work.

    I even managed to wangle out of RM an actual guide to getting the server over, after they tried to get an engineer booked in to "sort out a move" as it was "complicated and not straightforward" - It actually was very straightforward.

SHARE:
+ Post New Thread

Similar Threads

  1. Successmaker VM
    By denon101 in forum Educational Software
    Replies: 5
    Last Post: 11th November 2010, 12:13 PM
  2. Symphony Maths or EducationCity vs Successmaker
    By Geoff in forum Educational Software
    Replies: 0
    Last Post: 3rd December 2008, 10:13 AM
  3. SuccessMaker Application Conflict
    By Midget in forum Educational Software
    Replies: 11
    Last Post: 4th January 2007, 08:22 PM
  4. rm successmaker install
    By edie209 in forum Educational Software
    Replies: 11
    Last Post: 1st November 2006, 11:06 AM
  5. Successmaker Pt2
    By edie209 in forum Educational Software
    Replies: 1
    Last Post: 21st September 2006, 10:45 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •