+ Post New Thread
Results 1 to 5 of 5
Coding Thread, CSS Problem in Coding and Web Development; Dont normally have issues with CSS but for the life me of I can't seem to get this work; URL: ...
  1. #1
    tsimons's Avatar
    Join Date
    Jul 2009
    Location
    Billericay, Essex
    Posts
    22
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    11

    CSS Problem

    Dont normally have issues with CSS but for the life me of I can't seem to get this work;

    URL: TMS Solutions (UK) | Computer Repair and Network Solutions

    I cant seem to remove the gaps between the DIVs ive tried everything..

    Code:
    Body{
    	background-image:url(../img/bgall.jpg);
    	background-repeat:repeat-x;
    	background-color:#767676;
    }
    #wrapper{
    	width:884px;
    	height:auto;
    	margin:auto;
    }
    #headbanner{
    	background-image:url(../img/header.jpg);
    	width:884px;
    	height:168px;
    	background-repeat:no-repeat;
    	margin:0px;
    }
    #navigation{
    	background-image:url(../img/navigation.png);
    	width:884px;
    	height:49px;
    	background-repeat:no-repeat;
    	margin:0px;
    }
    #content{
    	background-image:url(../img/contentbg.jpg);
    	background-position:top;
    	background-repeat:repeat-x;
    	background-color:#FFF;
    	width:884px;
    	height:auto;
    	margin:0px;
    }
    #contentbottom{
    	background-image:url(../img/contentbottom.png);
    	background-repeat:no-repeat;
    	width:884px;
    	height:19px;
    	margin:0px;
    }
    Ive tried to change the margin to "margin: 0px auto;" and also "margin:0px;" but nothing works?

    Any ideas? I really dont like using absolute positioning...
    Last edited by tsimons; 8th February 2010 at 04:34 PM.

  2. #2

    Join Date
    Feb 2010
    Posts
    40
    Thank Post
    8
    Thanked 4 Times in 4 Posts
    Rep Power
    10

    What Gaps

    Hi

    Which DIVS are causing you the issue, I don't see any in IE7

    Paul

  3. #3
    Mako's Avatar
    Join Date
    Apr 2009
    Location
    North Yorkshire
    Posts
    431
    Thank Post
    50
    Thanked 107 Times in 81 Posts
    Rep Power
    71
    Quote Originally Posted by Paul_Fielder View Post
    Hi

    Which DIVS are causing you the issue, I don't see any in IE7

    Paul
    Using IE8 here, and I see the issue. Using Ie7 cures the problem, but it needs recifying for browser compatability.

    You may need to specify negative margins in order to bring the divs together, and specify each margin i.e top, bottom, left, right.

    E.g;
    Code:
    margin: -10px 0px 0px 0px;
    Will bring the element closer towards the element above it. Looks like you need to alter the margins of #content and #contentbottom. Play around with the values until they slot perfectly together.

  4. Thanks to Mako from:

    tsimons (8th February 2010)

  5. #4
    tsimons's Avatar
    Join Date
    Jul 2009
    Location
    Billericay, Essex
    Posts
    22
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    11
    Quote Originally Posted by Mako View Post
    You may need to specify negative margins in order to bring the divs together, and specify each margin i.e top, bottom, left, right.

    E.g;
    Code:
    margin: -10px 0px 0px 0px;
    Will bring the element closer towards the element above it. Looks like you need to alter the margins of #content and #contentbottom. Play around with the values until they slot perfectly together.

    Wonderful, such a simple fix , you know when you work on somthing so long you get lost in things you have already done..

    lol

    Thanks Mako!

    Last edited by tsimons; 8th February 2010 at 04:34 PM.

  6. #5
    Mako's Avatar
    Join Date
    Apr 2009
    Location
    North Yorkshire
    Posts
    431
    Thank Post
    50
    Thanked 107 Times in 81 Posts
    Rep Power
    71
    You're welcome, Tom.

    Time for me to go home, methinks.

SHARE:
+ Post New Thread

Similar Threads

  1. CSS
    By jeffy in forum EduGeek Joomla 1.5 Package
    Replies: 0
    Last Post: 22nd January 2009, 03:13 AM
  2. IE 7.0 ROK Slideshow Module in Joomla. CSS / IE Problem
    By bensewell in forum Web Development
    Replies: 0
    Last Post: 6th September 2007, 01:47 PM
  3. CSS gurus!
    By nickje in forum Web Development
    Replies: 2
    Last Post: 12th June 2007, 11:42 AM
  4. IE7 css problem
    By netadmin in forum Web Development
    Replies: 19
    Last Post: 14th March 2007, 09:41 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •