+ Post New Thread
Page 3 of 3 FirstFirst 123
Results 31 to 35 of 35
Coding Thread, MIT App Inventor 2 emulator in Coding and Web Development; Hello, We're looking to roll the emulator too. I've V1 already out with a simple /silent or /quiet switch (can't ...
  1. #31

    Join Date
    May 2008
    Location
    UK
    Posts
    53
    Thank Post
    7
    Thanked 2 Times in 2 Posts
    Rep Power
    14
    Hello,
    We're looking to roll the emulator too.
    I've V1 already out with a simple /silent or /quiet switch (can't remember which), but for this new V2, I can't find the silent install switch...any ideas? Or is there an MSI somewhere? Or how did you do deploy it?
    Cheers,
    Jon

  2. #32

    Join Date
    May 2008
    Location
    UK
    Posts
    53
    Thank Post
    7
    Thanked 2 Times in 2 Posts
    Rep Power
    14
    Bumpety bump bump?

    EDIT: found out you can use AppInventor_Setup_Installer_v_2_2.exe /S
    My bad for not realising that CAPS makes a difference, was using lower case s combinations.
    BUT...it won't silently uninstall like the old version. Also need to change the %homepath% variable to %localappdata% as the old version wouldn't run.
    Guess I have to do the old image way...
    Last edited by jonspurs; 27th March 2014 at 04:26 PM.

  3. #33

    Join Date
    May 2008
    Location
    UK
    Posts
    53
    Thank Post
    7
    Thanked 2 Times in 2 Posts
    Rep Power
    14
    Ok this is how I done it for anyone else curious...using RM App Wiz / WinInstall LE:
    1. Run first scan as usual.
    2. Install AppInventor.
    3. Edit in notepad run-emulator.bat from:
    C:\Program Files\AppInventor\commands-for-Appinventor
    Lines 9 and 43 contain %HOMEPATH%
    Change this to %LOCALAPPDATA%
    4. Save and close
    5. Go to C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup (the ALLUSERSPROFILE windows variable)
    6. In the above folder, delete the shortcut to aistarter (otherwise when you deploy the software, the aistarter cmd box will always load up for any user which is annoying)
    7. Close all windows and run 2nd scan.
    8. Manually add shortcut of AiStarter to your Program Sets and instruct kids to launch this before trying to run the emulator.
    9. Students must have the 'batch processing' (I think it's called that) option in the RMMC.
    10. Bob is your uncle.

    I didn't mess around with localhost or 127.0.0.1 exceptions or .appinventor folders...basically used AppInventor V1 experience with this.

    Jon

  4. #34
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    497
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    24
    Quote Originally Posted by jonspurs View Post
    Ok this is how I done it for anyone else curious...using RM App Wiz / WinInstall LE:
    1. Run first scan as usual.
    2. Install AppInventor.
    3. Edit in notepad run-emulator.bat from:
    C:\Program Files\AppInventor\commands-for-Appinventor
    Lines 9 and 43 contain %HOMEPATH%
    Change this to %LOCALAPPDATA%
    4. Save and close
    5. Go to C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup (the ALLUSERSPROFILE windows variable)
    6. In the above folder, delete the shortcut to aistarter (otherwise when you deploy the software, the aistarter cmd box will always load up for any user which is annoying)
    7. Close all windows and run 2nd scan.
    8. Manually add shortcut of AiStarter to your Program Sets and instruct kids to launch this before trying to run the emulator.
    9. Students must have the 'batch processing' (I think it's called that) option in the RMMC.
    10. Bob is your uncle.

    I didn't mess around with localhost or 127.0.0.1 exceptions or .appinventor folders...basically used AppInventor V1 experience with this.

    Jon
    Aren't you concerned that the students can now process batch scripts though, as in step .9? I wouldn't want to enable that here for security concerns.

  5. #35

    Join Date
    May 2008
    Location
    UK
    Posts
    53
    Thank Post
    7
    Thanked 2 Times in 2 Posts
    Rep Power
    14
    We've only given elevated access to a handful of students...and if we don't allow it, they cannot use the emulator, and they still won't have admin rights. Had App Inventor V1 for a while and that has been ok in the past...touchwood.



SHARE:
+ Post New Thread
Page 3 of 3 FirstFirst 123

Similar Threads

  1. MIT App Inventor Emulator
    By stevenkellett in forum Windows
    Replies: 21
    Last Post: 30th July 2014, 04:42 PM
  2. MIT app inventor?
    By BassTech in forum Windows 7
    Replies: 31
    Last Post: 13th December 2013, 11:22 AM
  3. MIT App Inventor Without Google account
    By dezt in forum How do you do....it?
    Replies: 6
    Last Post: 23rd October 2013, 09:43 AM
  4. MIT App Inventor Silent Install
    By Zoom7000 in forum Educational Software
    Replies: 9
    Last Post: 8th April 2013, 10:33 AM
  5. Android App Inventor
    By Dos_Box in forum Netbooks, PDA and Phones
    Replies: 4
    Last Post: 10th September 2010, 09:50 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •