+ Post New Thread
Results 1 to 7 of 7
Cloud Services Thread, ADFS SSO slow on premises, but quick offsite?! in Technical; Just throwing this one out there. Got a small problem (and it is only a small one) with our O365 ...
  1. #1
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,256
    Thank Post
    218
    Thanked 231 Times in 200 Posts
    Rep Power
    74

    ADFS SSO slow on premises, but quick offsite?!

    Just throwing this one out there.

    Got a small problem (and it is only a small one) with our O365 and ADFS/SSO system. When a user opens their browser (mostly IE10/IE11, small scattering of Firefox) and goes to the email link, it signs in to Outlook Web App as you would expect. The problem is how long it takes for that initial sign-on.

    You open a browser, click email and it can then sit there thinking for 12 to 14 seconds before it brings up the Inbox. Once email is open it all runs perfectly. If I were to open a different website (not closing the browser) and then come back to the email it opens almost instantly. Close the browser and open it again and you're back to the long wait.

    Interestingly, when accessing the email from outside school, once you enter your username and password it logs in within 2 to 3 seconds!

    Any clues as to why it runs so slow on site? It all functions, it's just the speed that's annoying. Staff seem to think the email is "down" because they have no patience!!

    Cheers

  2. #2
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,256
    Thank Post
    218
    Thanked 231 Times in 200 Posts
    Rep Power
    74
    - any thoughts? @jamesbmarshall @EduTech ??

  3. #3

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,074
    Thank Post
    160
    Thanked 937 Times in 731 Posts
    Blog Entries
    3
    Rep Power
    275
    If you lookup your STS Endpoint URL (sts.domain.co.uk / or what ever you have used) does it resolve to the internal IP address? or External when on the corp/domain network.

    James.

  4. #4
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,256
    Thank Post
    218
    Thanked 231 Times in 200 Posts
    Rep Power
    74
    umm? to be honest im not sure what you mean? I don't seem to have anything related to sts - what is it and where should it be pointing to?

  5. #5
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,256
    Thank Post
    218
    Thanked 231 Times in 200 Posts
    Rep Power
    74
    ok, just checked on this. we use adfs.domain.com instead of sts.domain.com an dyes it resolves to the internal ip address

  6. #6
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,256
    Thank Post
    218
    Thanked 231 Times in 200 Posts
    Rep Power
    74
    Anything else I can check?

  7. #7
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,256
    Thank Post
    218
    Thanked 231 Times in 200 Posts
    Rep Power
    74
    Still slow when onsite. Any other thoughts?

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 4
    Last Post: 17th April 2013, 03:46 PM
  2. Replies: 2
    Last Post: 14th December 2010, 09:16 PM
  3. Exchange OWA very slow on admin network
    By dgsmith in forum Internet Related/Filtering/Firewall
    Replies: 3
    Last Post: 8th September 2009, 11:23 AM
  4. [Pics] Originally Posted As Humerous On FailBlog: But NOT Funny
    By DaveP in forum Jokes/Interweb Things
    Replies: 0
    Last Post: 18th August 2009, 06:18 PM
  5. Leopard install works on one but not the other
    By thegrassisgreener in forum Mac
    Replies: 2
    Last Post: 19th November 2007, 02:55 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •