+ Post New Thread
Results 1 to 10 of 10
Cloud Services Thread, Office365 - Relay in Technical; Has anyone got Office365 to work with their copiers, for emailing? I've tried setting up a SMTP Virtual Server in ...
  1. #1

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,259
    Thank Post
    404
    Thanked 633 Times in 578 Posts
    Rep Power
    185

    Office365 - Relay

    Has anyone got Office365 to work with their copiers, for emailing? I've tried setting up a SMTP Virtual Server in IIS to relay on to Office365 but it's not sending any emails.

    Any advice / instructions appreciated!

  2. #2

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,074
    Thank Post
    160
    Thanked 937 Times in 731 Posts
    Blog Entries
    3
    Rep Power
    275
    Hi Mate,

    This KB Article should help you out. How to set up an SMTP relay in Office 365

    Regards,
    James.

  3. #3

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,259
    Thank Post
    404
    Thanked 633 Times in 578 Posts
    Rep Power
    185
    Figured it! The sender name on the actual devices has to be the same as the one used to authenticate. I'd forgot to change it over. Doh!
    Last edited by Edu-IT; 9th May 2013 at 03:29 PM.

  4. #4
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,258
    Thank Post
    218
    Thanked 232 Times in 200 Posts
    Rep Power
    74
    I'm really struggling getting this to work I've used the setting from the supplied link but nothing is getting through. Does anyone have a step-by-step that is easy to follow to allow me to setup my Backup Exec to send email using Office 365 SMTP??

    Cheers

  5. #5

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,259
    Thank Post
    404
    Thanked 633 Times in 578 Posts
    Rep Power
    185
    Quote Originally Posted by themightymrp View Post
    I'm really struggling getting this to work I've used the setting from the supplied link but nothing is getting through. Does anyone have a step-by-step that is easy to follow to allow me to setup my Backup Exec to send email using Office 365 SMTP??

    Cheers
    Set up a local IIS relay? That's what I had to do here.

  6. #6
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,258
    Thank Post
    218
    Thanked 232 Times in 200 Posts
    Rep Power
    74
    That's what I've tried doing by following the above instructions. I don't know if I've got it set right though as nothing is coming through.

    Although...... just thinking - I'm going to need to open firewall port 587 aren't I? For the IIS relay machine?

  7. #7

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,212 Times in 761 Posts
    Rep Power
    395
    If you are just sending the email to yourself (or other internal users), then just set the SMTP server to whatever your incoming MX is on port 25, with no authentication. A mail server has to accept mail for its own users with no auth, or every mail system outside your domain would have to have a username and password to send you email.

  8. #8
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,258
    Thank Post
    218
    Thanked 232 Times in 200 Posts
    Rep Power
    74
    Which is how I had things setup on the SMTP server first off. To be clear:

    • I have no onsite Exchange server
    • Our email system is Office 365
    • Our smtp server for office 365 is supposedly smtp.office365.com


    I have setup an onsite IIS server with SMTP server features. I have setup this server using both of these configuration options:

    How to set up an SMTP relay in Office 365

    How to enable on-premises applications and devices to send mail to Office 365 users

    Neither one works. However I have got a build up of unsent messages in the mailroot\queue folder

    Do I need to specifically open port 25 to this server? That may sound like a complete noob question but our previous email provider gave us a SMTP relay address to use so I've never had to set this bit up before

  9. #9

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,212 Times in 761 Posts
    Rep Power
    395
    You shouldn't need an SMTP relay at all. On the device that needs to send email, specify whatever server is listed in your domain's MX record as the "relay" server.

    If that isn't working, it is likely a firewall issue (which would also cause the issue you're seeing with the relay), but without being familiar with the existing firewall config it's hard to say for certain.

  10. #10
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,258
    Thank Post
    218
    Thanked 232 Times in 200 Posts
    Rep Power
    74
    Sorted it, was me being a tool. I needed to have the sending application i.e. Backup Exec pointing to my internal SMTP server over port 25. The SMTP server itself needed to point to smtp.office365.com over port 587 ! I was trying it with both set as either 25 or 587



SHARE:
+ Post New Thread

Similar Threads

  1. debian gateway relaying appletalk aagh!
    By browolf in forum *nix
    Replies: 14
    Last Post: 17th October 2009, 11:56 PM
  2. Exchange SMTP relay probs
    By MK-2 in forum Windows
    Replies: 3
    Last Post: 7th August 2008, 02:49 PM
  3. Exchange SMTP relay problem! Plz Help
    By screwuphead in forum Wireless Networks
    Replies: 1
    Last Post: 21st January 2008, 08:50 PM
  4. Replies: 3
    Last Post: 19th April 2007, 02:50 PM
  5. Replies: 7
    Last Post: 14th September 2006, 11:37 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •