+ Post New Thread
Results 1 to 9 of 9
Cloud Services Thread, Set "Allow proxies for shared networks" For All Users on Chromebooks in Technical; I have recently purchased a bunch of chromebooks for the school district I work for. I am trying to figure ...
  1. #1

    Join Date
    Mar 2013
    Posts
    5
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Angry Set "Allow proxies for shared networks" For All Users on Chromebooks

    I have recently purchased a bunch of chromebooks for the school district I work for. I am trying to figure out a way to set the flag "Allow proxies for shared networks" for every user that logs on to the chromebooks. We have a proxy server for content filtering and firewall purposes, but I have found the only way to make it work fully, and allow full browsing of the internet is to check the box for "Allow proxies for shared networks." This has to be done on each user. I can't hand this to a 3rd grader and have him do it. Does anyone know of a way to set it for all users?

    I have also found that if I configure my proxy settings manually on the box without using the google apps management console, I can get it to work for full browsing, but I have to not enter anything in for the SOCKS host. I only configure the HTTP, HTTPS, and FTP proxy settings. Again, I can't hand this to a student to do. If I try to do it through the google apps management console, it won't let me leave the SOCKS host box blank. Does anyone have a solution here? Thanks.

  2. #2

    Join Date
    May 2013
    Posts
    5
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    In the UK we have lots of schools successfully using Google apps and Chromebooks & managing them using the Management Control Panel.

    In both the US & UK you get access to both email and telephone support direct to Google staff (details are in your management control panel under support) - would encourage you to give the support team a call as they should be able to help get your admin settings right & resolve your problem.

    Hope this helps

  3. #3

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,529
    Thank Post
    513
    Thanked 2,406 Times in 1,862 Posts
    Blog Entries
    24
    Rep Power
    822
    We did all the configuration via the admin panel for our Google Apps. It sounds like you've been configuring them individually rather than via the panel?

  4. #4

    Join Date
    Feb 2011
    Location
    Dudley
    Posts
    119
    Thank Post
    17
    Thanked 32 Times in 22 Posts
    Rep Power
    12
    I am also currently experiencing the same issue as AngryTech. I have been in daily communication for the last couple of weeks with a Google Chromebook Specialist trying to successfully connect these devices on our network via our proxy server but am still having limited success.

    I am as of today in the same situation of each user needing to check the 'allow proxies for shared networks' setting to connect to the internet or apps and am awaiting an answer as to whether this setting can be applied centrally.

    I can also confirm that if proxy settings are manually entered in admin panel then it seems you need to enter settings for all the protocols which is not the case when entering the settings on the device itself.

    I will update if I get any further with this...

  5. #5


    Join Date
    May 2009
    Posts
    2,878
    Thank Post
    258
    Thanked 767 Times in 582 Posts
    Rep Power
    269
    Quote Originally Posted by spadam View Post
    I will update if I get any further with this...
    Please do, preferably before this drives me round the bend.
    Last edited by pcstru; 28th May 2013 at 01:47 PM.

  6. #6

    Join Date
    Feb 2011
    Location
    Dudley
    Posts
    119
    Thank Post
    17
    Thanked 32 Times in 22 Posts
    Rep Power
    12
    The reply from Google is that it is not possible to set the allow proxies for shared networks setting from the admin panel and that this is intentional due to the potential security problems that this may cause. However, they are considering this for a future update but as always no clue as to when.

    If users select this option when they first sign in on a device it will be stored locally on that device for future sessions providing local data storage is enabled for users.

    This is far from ideal in our school but I guess it is something that we will have to live with for now. At least now we are
    In a position where we can do something with the Chrome books we have which until last week was not the case.

  7. #7
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    816
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    39
    I've had the same problem and wasted a few days on this. The only solution I could find to allow the Chromebooks to work at school and off-site, without relying on the "Allow proxies for shared networks" checkbox, was to switch to using PAC files. I made one PAC file for staff, and one for students, then set those as user settings against staff and student OUs. If you use the Citrix Receiver for Chromebooks you will need a proxy exception for the loopback address (127.0.0.1) in the PAC file, as it actually connects to itself to launch the session. You'll also find the Citrix Receiver for Chromebooks just locks up the entire machine when too much content changes on the screen and is effectively unusable.

  8. Thanks to morganw from:

    spadam (4th June 2013)

  9. #8

    Join Date
    Feb 2011
    Location
    Dudley
    Posts
    119
    Thank Post
    17
    Thanked 32 Times in 22 Posts
    Rep Power
    12
    Quote Originally Posted by morganw View Post
    then set those as user settings against staff and student OUs.
    Thanks for this. I have now also entered the PAC setting against the user groups as well as against the network and no longer need the 'allow proxies for shared networks' checkbox.

  10. #9

    Join Date
    Jun 2013
    Posts
    2
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I found one way around this, In the GAPPS Panel if you create the wifi network under both the user and device policies then you are no longer required to tick the box and they seem to just work.

  11. Thanks to jsacre from:

    Bev (25th September 2013)

SHARE:
+ Post New Thread

Similar Threads

  1. [MS Office - 2007] Forcing a custom normal.dotm for all users on a server 2003 network
    By bigjb in forum Office Software
    Replies: 3
    Last Post: 8th April 2014, 03:17 PM
  2. Clear IE addons for all users on RM CC4?
    By gsk in forum How do you do....it?
    Replies: 0
    Last Post: 6th January 2011, 11:46 AM
  3. Replies: 3
    Last Post: 26th August 2010, 06:09 PM
  4. Replies: 8
    Last Post: 23rd May 2009, 07:25 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •