+ Post New Thread
Results 1 to 10 of 10
Cloud Services Thread, Google Apps and sync with AD in Technical; We ar movig our students to Gmail and i have a couple of issues 1) How do we get it ...
  1. #1

    Join Date
    May 2006
    Location
    West Kirby
    Posts
    89
    Thank Post
    5
    Thanked 3 Times in 3 Posts
    Rep Power
    17

    Google Apps and sync with AD

    We ar movig our students to Gmail and i have a couple of issues

    1) How do we get it to sync passwords with our AD on windows 2008 r2, I ahve seen a mixture of solutions but not a really clear step by step

    I have installed GADS and that works great I have installed the google password sync but nothing happens even when i change password it still does not logmein

    Is it that i have to wait a longer for sync to happen or am i missing something some people are talking about sha1filter dll but i read nothing about thaton google help.

    I would even consinder single sign on but we CANNOT pay anything. I know my way round IIS so if it something we can do for free then i will consider that option.

    If someone could be kind enough to give a step throu guid on getting this to work please would save me going mental.

    Config this end Windows 2008 RC2 RM cc4.3

    Thanks
    Stuart

  2. #2


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    I'd go for SSO.
    Do you have moodle? theres an SSO module here:
    git.catalyst.net.nz Git - moodle-r2.git/summary

    Other Opensource SSO's that will work with google apps are:
    SimpleSAMLphp
    Shibboleth - Home

  3. #3
    Netman's Avatar
    Join Date
    Jul 2005
    Location
    56.343515, -2.804118
    Posts
    911
    Thank Post
    367
    Thanked 190 Times in 143 Posts
    Rep Power
    54
    I think GADS and sha1filter is now old hat - Take a look at GAPS Google Apps Password Sync (GAPS) - Google Apps Help No personal experience of this though as we used to use GADS and sha1filter but then I decided to just make our users have separate passwords for AD and Google Apps - they can have them the same or different (recommended) - I leave it up to them!

  4. #4

    Join Date
    May 2006
    Location
    West Kirby
    Posts
    89
    Thank Post
    5
    Thanked 3 Times in 3 Posts
    Rep Power
    17
    I have tried the GAPS but it does not work with our ad

    I am stuck

    Any Advice
    CC4 windows 2008 r2 servers ,reverse password encryption NOT enabled.

  5. #5
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,485
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    GADS doesn't run automatically - we have a scheduled task set up to run it once an hour. GAPS would be preferable though, as that is live.

  6. #6

    Join Date
    May 2006
    Location
    West Kirby
    Posts
    89
    Thank Post
    5
    Thanked 3 Times in 3 Posts
    Rep Power
    17
    Got GADS working and creating the users and set schdule but cannot get GAPS working

    I do not have reverse password encryption tick in AD do i need that some forums say yes and some say no.
    Is it because it is a CC$ RM AD i know htey modify it for themselves

    THanks
    Stuart

  7. #7

    Join Date
    Jul 2007
    Location
    West Sussex
    Posts
    262
    Thank Post
    35
    Thanked 11 Times in 11 Posts
    Rep Power
    16
    Hi Stuart,
    Did you ever get GAPS working? I'm just staring to set it up, have got Directory sync working but I can't even get the page to load to grant OAuth access to Gaps in IE?!? It works on a workstation just not on 2008 R2 server, I suspect an IE setting. Did you have this issue?

    Thanks
    Dan

  8. #8
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,485
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    Quote Originally Posted by IT_Man_Dan View Post
    I can't even get the page to load to grant OAuth access to Gaps in IE?!?
    I had that when installing GAPS a few days ago. In desperation, I selected the box which says "I don't have a password" and it took me to a Google login page, where I logged in with my admin account credentials and it then authenticated!

    I haven't actually tried using it to sync a password yet though...

  9. #9

    Join Date
    Jul 2007
    Location
    West Sussex
    Posts
    262
    Thank Post
    35
    Thanked 11 Times in 11 Posts
    Rep Power
    16
    I only have the Option saying 'I can't access my account' that then takes me to the forgotten password page :-(
    Before launching the IE browser there is an option saying 'Yes I have a password' but it is greyed out so I can't select it.

    It's driving me crazy right now

  10. #10

    Join Date
    Jul 2007
    Location
    West Sussex
    Posts
    262
    Thank Post
    35
    Thanked 11 Times in 11 Posts
    Rep Power
    16
    I'VE CRACKED IT

    Javascript wasn't enabled in IE settings on Server.

    For anyone who needs to know:
    Internet Options>Security>Custom Level>Scripting>Set Active Scripting to Enabled = Problems solved...

    Thanks
    Dan

SHARE:
+ Post New Thread

Similar Threads

  1. Setting up Google Apps - Syncing with AD questions
    By IT_Man_Dan in forum Cloud Services
    Replies: 3
    Last Post: 12th July 2012, 07:09 AM
  2. Moodle 2.x with integrated Google Apps and GMail - anyone had success?
    By Bumbles in forum Virtual Learning Platforms
    Replies: 0
    Last Post: 24th November 2011, 10:19 AM
  3. iPhone Apps not syncing with iTunes!
    By Scottyboy99 in forum Mac
    Replies: 1
    Last Post: 8th February 2010, 09:38 AM
  4. Google Apps and CC3
    By emdudley in forum Web Development
    Replies: 4
    Last Post: 11th July 2009, 08:45 PM
  5. Open Directory Sync with AD
    By binky in forum General Chat
    Replies: 0
    Last Post: 5th June 2009, 08:48 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •