+ Post New Thread
Page 4 of 5 FirstFirst 12345 LastLast
Results 46 to 60 of 73
Cloud Services Thread, Office 365 Email Segregation in Technical; We set up 2 Gals, 1 for students and one for teachers. Teachers can see students but not the other ...
  1. #46

    Join Date
    Dec 2012
    Posts
    10
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    We set up 2 Gals, 1 for students and one for teachers. Teachers can see students but not the other way around.

  2. #47
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,201
    Thank Post
    211
    Thanked 222 Times in 191 Posts
    Rep Power
    72
    Quote Originally Posted by waltflanagan View Post
    We set up 2 Gals, 1 for students and one for teachers. Teachers can see students but not the other way around.
    Any chance you can outline how you did this? This is exactly what I am trying to do (although I would be really happy if the student GAL was empty! If students see nothing on the GAL it would be my ideal scenario, with staff seeing everyone).

    The commands I have been trying are coming back with 'unrecognized name of a cmdlet'.

    Once I have connected and imported the session, I am trying New-AddressBookPolicy, New-AddressList, New-GlobalAddressList - all without success I have been able to switch on ABP by using the command Set-TransportConfig -AddressBookPolicyRoutingEnabled $True but this is as far as I'm getting.

    Any guidance would be appreciated

    Ta

  3. #48
    jamesbmarshall's Avatar
    Join Date
    Feb 2010
    Location
    Reading, UK
    Posts
    513
    Thank Post
    26
    Thanked 228 Times in 158 Posts
    Rep Power
    85
    If you're trying this as soon as you've enabled the ABPs you might want to go and have a coffee and come back since it can take a while for the policy to update.

    I wrote a blog post that might also help (principle is the same, even if the subject matter is different): Alumni Address Book Policy in Office 365 Education - UK Education Cloud Blog - Site Home - MSDN Blogs

  4. 2 Thanks to jamesbmarshall:

    Rick2134 (24th May 2013), themightymrp (21st May 2013)

  5. #49
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,201
    Thank Post
    211
    Thanked 222 Times in 191 Posts
    Rep Power
    72
    This is perfect thank you! I also have realised straight away that I had missed off some of the Roles that I needed

  6. #50
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,201
    Thank Post
    211
    Thanked 222 Times in 191 Posts
    Rep Power
    72
    @jamesbmarshall - once again, thankyou! I have now successfully setup my GAL's the way I wanted it by modifying the guide you posted above.

    Cheers

    PS - I don't know if it is already posted on here somewhere but if you want to set the language and time zone for all your users (to prevent OWA asking upon first login), you can use this command if you are in the UK:

    Code:
    get-mailbox | set-mailboxregionalconfiguration -language 2057 -timezone "GMT Standard Time"
    For other regions refer to this page : https://www.cogmotive.com/blog/offic...-in-office-365

  7. 3 Thanks to themightymrp:

    AlexB (9th July 2013), Rick2134 (24th May 2013), zag (22nd May 2013)

  8. #51
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,201
    Thank Post
    211
    Thanked 222 Times in 191 Posts
    Rep Power
    72
    I think I may have an issue with my student GAL Once I set the students to be hidden from address lists, they a) don't appear as members of my 'AL_Students' and b) are unable to receive any email! They can send them though :-/

    The error I get back when I email them is

    Code:
    Diagnostic code = NoDiagnostic; Reason code = TransferFailed; Status code = 532
                <AMSPR07MB113.eurprd07.prod.outlook.com #5.3.2 smtp;532 5.3.2 STOREDRV.Deliver; Missing or bad StoreDriver MDB properties>
    If I unhide them they receive emails fine - but then they appear in the contacts of staff which I don't want.

    Any ideas?

  9. #52
    jamesbmarshall's Avatar
    Join Date
    Feb 2010
    Location
    Reading, UK
    Posts
    513
    Thank Post
    26
    Thanked 228 Times in 158 Posts
    Rep Power
    85
    This is one of those times where I wish I'd bookmarked the page where I saw this information... I think there is/was a bug if you used ABPs and hiding from address lists together which caused some interesting routing issues but I can't put my hands on the page now!

    Log a service request.


    EDIT: Found it! See the response from Greg Taylor: Exchange 2013 Address Book Policy Routing Agent Issue with Mailboxes Hidden From the Address Lists

  10. Thanks to jamesbmarshall from:

    themightymrp (18th September 2013)

  11. #53
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,201
    Thank Post
    211
    Thanked 222 Times in 191 Posts
    Rep Power
    72
    So its a bug with no solution as yet May have to modify things slightly then....

  12. #54
    jamesbmarshall's Avatar
    Join Date
    Feb 2010
    Location
    Reading, UK
    Posts
    513
    Thank Post
    26
    Thanked 228 Times in 158 Posts
    Rep Power
    85
    Do your staff not have an ABP which does not​ include the student AL?

  13. #55
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,201
    Thank Post
    211
    Thanked 222 Times in 191 Posts
    Rep Power
    72
    Actually no, that would have been a good idea I realize now. I thought I could have got away without it if I hadn't come across this bug. However I am now creating a staff ABP

  14. #56
    jamesbmarshall's Avatar
    Join Date
    Feb 2010
    Location
    Reading, UK
    Posts
    513
    Thank Post
    26
    Thanked 228 Times in 158 Posts
    Rep Power
    85
    Quote Originally Posted by themightymrp View Post
    However I am now creating a staff ABP
    Good man! Clearly, the bug needs fixing, and I'm sure it will but for now that's probably the more ... logical? way to handle it!

  15. #57
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,201
    Thank Post
    211
    Thanked 222 Times in 191 Posts
    Rep Power
    72
    Any idea how long it takes to populate address lists etc with names based on a recipient filter? I am only assigning it to me at the moment and so far so good but it hasn't got a complete list of staff......

  16. #58
    Boredguy's Avatar
    Join Date
    Jun 2011
    Location
    Swindon
    Posts
    568
    Thank Post
    3
    Thanked 128 Times in 119 Posts
    Rep Power
    50
    It can take a couple of hours.

    I created a new Address list yesterday, but it wasn't until an hour after I created the Offline Address book referencing it today, that entries appeared.

  17. Thanks to Boredguy from:

    themightymrp (18th September 2013)

  18. #59
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,201
    Thank Post
    211
    Thanked 222 Times in 191 Posts
    Rep Power
    72
    OK, daft question - why when I try to untick the "Hide from address lists" box for a student do I get the following error?

    Code:
    The operation on mailbox "XXXX" failed because it's out of the current user's write scope. The action 'Set-Mailbox', 'HiddenFromAddressListsEnabled', can't be performed on the object 'XXXX' because the object is being synchronized from your on-premises organization. This action should be performed on the object in your on-premises organization.
    This also happens from Powershell. It must have worked before because I hid them en-masse using a piped powershell command!!

  19. #60
    jamesbmarshall's Avatar
    Join Date
    Feb 2010
    Location
    Reading, UK
    Posts
    513
    Thank Post
    26
    Thanked 228 Times in 158 Posts
    Rep Power
    85
    If you're syncing with your local AD you need to set the attribute in AD and wait for DirSync to push it back up!

SHARE:
+ Post New Thread
Page 4 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Replies: 26
    Last Post: 12th March 2014, 11:36 PM
  2. Office 365 email account for spiceworks helpdesk
    By scholes99 in forum Cloud Services
    Replies: 5
    Last Post: 13th June 2013, 10:26 AM
  3. Migrating staff email to office 365
    By tj2419 in forum Cloud Services
    Replies: 16
    Last Post: 6th October 2012, 03:25 AM
  4. Replies: 2
    Last Post: 31st May 2012, 01:27 AM

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •