+ Post New Thread
Results 1 to 3 of 3
AV and Multimedia Related Thread, sanyo xe40 not starting in Technical; Hi We have a problem with one of our XE40's The red power light comes on at start, but then ...
  1. #1

    Join Date
    Oct 2009
    Location
    Northants
    Posts
    20
    Thank Post
    2
    Thanked 1 Time in 1 Post
    Rep Power
    0

    sanyo xe40 not starting

    Hi
    We have a problem with one of our XE40's
    The red power light comes on at start, but then nothing. I've checked that the remote is working on other XE40's and and also that other remotes won't work on it either. After speaking to Promethean, I've tried holding menu+image to see if the channels needed altering but no luck.
    The bulb isn't that old, any ideas as to what I can try?
    Thanks

  2. #2

    Join Date
    Jan 2009
    Location
    Kent
    Posts
    18
    Thank Post
    5
    Thanked 3 Times in 3 Posts
    Rep Power
    20
    The XE40 has a trouble with a heat switch that if it reaches a certain temperature it will prevent it from turning on and you will need to manually reset it by stripping it down to the mainboard.

    Could possibly be that, i had that problem with one this week and had to strip it down

  3. Thanks to AD2K3 from:

    percy (19th November 2010)

  4. #3

    Join Date
    Oct 2009
    Location
    Northants
    Posts
    20
    Thank Post
    2
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I stripped it down, reset the switch, still red. So I blasted it with compressed air while I had the cover off and then reset it again. I think a combination of both these actions 'persuaded' it to fire up...!
    So - cheers for the advice.

SHARE:
+ Post New Thread

Similar Threads

  1. Cleaning the Sanyo PLC-XE40 projector
    By Gromit in forum Hardware
    Replies: 77
    Last Post: 3rd May 2013, 09:05 PM
  2. Sanyo PLC-XE40 will not startup
    By Skinny in forum Hardware
    Replies: 5
    Last Post: 8th October 2010, 02:33 PM
  3. Sanyo PLC-XE40 Fault
    By alameals in forum Promethean Direct Support
    Replies: 5
    Last Post: 23rd September 2010, 10:17 AM
  4. Sanyo PLC-XE40 Projector Not Starting Up
    By avr34 in forum Hardware
    Replies: 0
    Last Post: 28th August 2010, 10:35 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •