+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 21
AV and Multimedia Related Thread, UF-55 Projector flickering problem in Technical; One of our SMART BoardTM 600i3 uf-55 projectors has started to flicker. This happens even when its not connected to ...
  1. #1

    Join Date
    Jan 2008
    Location
    Essex / Suffolk border
    Posts
    187
    Thank Post
    35
    Thanked 23 Times in 14 Posts
    Rep Power
    16

    UF-55 Projector flickering problem

    One of our SMART BoardTM 600i3 uf-55 projectors has started to flicker. This happens even when its not connected to a computer. Its an irregular flicker but occurring constantly.

    Projector is around a year old, but bulb life is at 1042 hours. Manual refers to tracking but this only applied when a computer is connected.

    Anyone any ideas? Thanks

  2. #2
    jamesreedersmith's Avatar
    Join Date
    Sep 2009
    Location
    Ruskington
    Posts
    1,104
    Thank Post
    77
    Thanked 242 Times in 216 Posts
    Rep Power
    74
    Its a faulty colour wheel in the projector - ring Steljes (the uk agent fot Smart) and get them to swap it out - i had one projector that had to be swapped three times in the space of a month for the same fault - the engineer admitted it was a design fault and they keep going - be careful though as they normally send recon units and these kept going wrong and in the end it was only fixed when they agreed to send a "new" projector that was apparently a later model that was less cerceptible to this fault.

    Cheers
    James

  3. Thanks to jamesreedersmith from:

    bertster (28th June 2010)

  4. #3

    Join Date
    Dec 2008
    Posts
    4
    Thank Post
    0
    Thanked 2 Times in 2 Posts
    Rep Power
    0
    Bertster
    Here's the number for them

    Steljes Technical Services - 08450 724 999

    Give them the seriel number and they will help you out

  5. Thanks to wizzard74 from:

    bertster (2nd July 2010)

  6. #4

    Join Date
    Nov 2010
    Location
    Kansas
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    We've had a score of SmartBoard UF55 projectors with that problem in our school district, and the projected waiting time is 2-3 weeks to get a replacement. Once you add the time it takes to work through the troubleshooting and RMA process a system is down for about a month. That's a very long time in the flow of a classroom.

  7. #5
    jamesreedersmith's Avatar
    Join Date
    Sep 2009
    Location
    Ruskington
    Posts
    1,104
    Thank Post
    77
    Thanked 242 Times in 216 Posts
    Rep Power
    74
    Smart have now "upgraded" the UF55 with the use of a rubber bung over one of the air vents on top! and a filter of some kind that cant be cleaned, is not visible and will eventually no doubt clog up and cause a different issue!

  8. #6

    Join Date
    Aug 2009
    Posts
    6
    Thank Post
    2
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Thanks folks, old thread alert but helped me out a treat!

  9. #7

    Join Date
    Sep 2009
    Posts
    136
    Thank Post
    1
    Thanked 9 Times in 8 Posts
    Rep Power
    11
    Yep helpful when within warranty, if not, as was the case with one of our projectors recently, you're stumped.

  10. #8

    Join Date
    Mar 2013
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    We have had this fault on 3 projectors that we support & we have found it is due to colour wheel irregular speed . We have found that removing the upper case & cleaning the dust out of the unit including the air vents cures the problem. be carefull around the colour wheel as it will break very easy as is made of thin glass. if youdo not have the skills to dissmantel the unit then contact a projector servicing site & ask for a deep clean . hope this is some help.

  11. #9

    Join Date
    Sep 2009
    Posts
    136
    Thank Post
    1
    Thanked 9 Times in 8 Posts
    Rep Power
    11
    Quote Originally Posted by TSAndrew View Post
    We have had this fault on 3 projectors that we support & we have found it is due to colour wheel irregular speed . We have found that removing the upper case & cleaning the dust out of the unit including the air vents cures the problem. be carefull around the colour wheel as it will break very easy as is made of thin glass. if youdo not have the skills to dissmantel the unit then contact a projector servicing site & ask for a deep clean . hope this is some help.
    Where's the colour wheel and how do you get to it?
    Will need to give this a go.

  12. #10

    Join Date
    Sep 2009
    Posts
    136
    Thank Post
    1
    Thanked 9 Times in 8 Posts
    Rep Power
    11
    ...just found out about this official cleaning kit - essentially a blower that pokes inside the unit that they put out to address the issue - apparently free to owners of this model. Anyone tried it, does it actually work?

    Cleaning your SMART UF55 or SMART UF55w projector (146144) - SMART Technologies

  13. #11

    Join Date
    Feb 2013
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I just called Canada / SMARTtech yesterday to order the kit, I'll let you know if it helps my UF-55

  14. #12

    Join Date
    Feb 2013
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    My cleaning kit came Thursday. It's neat that it clips on top with a straw that aims the air from a bulb down into the color wheel. It seems to have fixed the problem so far!ImageUploadedByEduGeek1368294768.682434.jpg

  15. #13

    Join Date
    Sep 2009
    Posts
    136
    Thank Post
    1
    Thanked 9 Times in 8 Posts
    Rep Power
    11
    Has anyone got the link to that product page for that projector mounting bracket that converts the UF55 arm for use with other projectors?

    It's here somewhere, but the forum search isn't working

    Cheers.

  16. #14

    Join Date
    Sep 2009
    Posts
    136
    Thank Post
    1
    Thanked 9 Times in 8 Posts
    Rep Power
    11
    ... figures, the moment I post that I find it. Nevermind.

  17. #15

    Join Date
    Jul 2013
    Location
    Crescent City CA
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by exim View Post
    Has anyone got the link to that product page for that projector mounting bracket that converts the UF55 arm for use with other projectors?

    It's here somewhere, but the forum search isn't working

    Cheers.
    That is exactly what I need. I tried doing a search but came up with nothing. Can anybody point me in the right direction?

    THANKS!
    --Dan

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. SOLVED Epson EMP74 output flickering red?
    By speckytecky in forum Hardware
    Replies: 2
    Last Post: 17th March 2010, 10:32 PM
  2. Sahara projector problem
    By SteveT in forum Hardware
    Replies: 8
    Last Post: 11th November 2008, 10:13 PM
  3. Different Sahara projector problem
    By The_Traveller in forum Hardware
    Replies: 5
    Last Post: 13th March 2007, 01:09 PM
  4. Netgear GS724T switches+light flickering question
    By Kyle in forum Wireless Networks
    Replies: 6
    Last Post: 4th January 2007, 08:42 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •