+ Post New Thread
Results 1 to 8 of 8
AV and Multimedia Related Thread, Epson EB-475w Projectors in Technical; Hi all. We're having some issues with our Epson EB-475w projectors at the moment. They were only installed around 18 ...
  1. #1

    Join Date
    Mar 2014
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Epson EB-475w Projectors

    Hi all. We're having some issues with our Epson EB-475w projectors at the moment. They were only installed around 18 months ago, but so far on a site with 64 projectors we've had 19 develop a fault whereby they start flickering. Having spoken with Epson and had them onsite (where they were nonplussed and admitted to not having seen this before), they took away a unit and determined that it was the lamps that were failing, less than half way through their expected lifetime. Seemingly, it was a bad batch of lamps, and they offered to replace any that started to flicker.
    However, we are now getting units that are starting to flicker again after having only been replaced a few weeks ago. This is somewhat worrying, and is an H&S concern as we have at least one student onsite who has photosensitive epilepsy. Has anyone else had any issues with these projectors? I'm getting Epson to come and site visit again, so we shall see what they say.

  2. #2

    Join Date
    Sep 2010
    Location
    Edinburgh
    Posts
    63
    Thank Post
    4
    Thanked 4 Times in 4 Posts
    Rep Power
    9
    Hi, We have a number of the 475W and 470's installed last summer. Not had any issues with them at all. Sorry thats not much help...

  3. #3

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,558
    Thank Post
    2,416
    Thanked 800 Times in 481 Posts
    Blog Entries
    2
    Rep Power
    552
    Quote Originally Posted by UnknownSoundman View Post
    Hi all. We're having some issues with our Epson EB-475w projectors at the moment. They were only installed around 18 months ago, but so far on a site with 64 projectors we've had 19 develop a fault whereby they start flickering. Having spoken with Epson and had them onsite (where they were nonplussed and admitted to not having seen this before), they took away a unit and determined that it was the lamps that were failing, less than half way through their expected lifetime. Seemingly, it was a bad batch of lamps, and they offered to replace any that started to flicker.
    However, we are now getting units that are starting to flicker again after having only been replaced a few weeks ago. This is somewhat worrying, and is an H&S concern as we have at least one student onsite who has photosensitive epilepsy. Has anyone else had any issues with these projectors? I'm getting Epson to come and site visit again, so we shall see what they say.
    Interesting you should say this, as some of mine have started to flicker, most are coming up to 1000 hours +.

    I've had issues with the interactive function, and again they have no idea what that is but started asking me about the locations of wireless access points and light fittings...

  4. #4

    Join Date
    Jan 2008
    Location
    South West
    Posts
    1,842
    Thank Post
    219
    Thanked 271 Times in 219 Posts
    Rep Power
    70
    I've got 13 475wi 's only one flickers, you can mitigate it temporarily by switching the lamp power mode eco / full..

  5. #5

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,573
    Thank Post
    1,652
    Thanked 506 Times in 309 Posts
    Rep Power
    221
    We have 485wi's here and so far no issues.

  6. #6
    agasiorowski's Avatar
    Join Date
    Mar 2013
    Location
    St Stephen
    Posts
    11
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Have you tried installing the software on a laptop/netbook and trying a direct VGA connection to the projector (avoiding the faceplate)? If the projector stops flickering, it could be a lost connection on your PC. We had an issue here with a similar model of projector and it turned out to be a fault VGA port on the PC. Not saying your issue would be the same but it is worth ruling it out.

    Kind regards,

    Andy

  7. #7

    Join Date
    Dec 2007
    Location
    Ipswich
    Posts
    148
    Thank Post
    3
    Thanked 24 Times in 24 Posts
    Rep Power
    19
    We don't have the W versions but we have a few 470s and 480s about that age (maybe a bit older) and never had the slightest issue with them. The one Wide projector we have (EB-595WI) is only 3 months old so not really long enough for it to have developed that fault

  8. #8

    Join Date
    Jul 2010
    Location
    County Durham
    Posts
    8
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Yes we have 60 Epson EB-475 onsite and we have had this a lot. Usually the flickering starts after 18 months. We have noticed that you only see the flickering once the projector has warmed up. Luckily with Epson's 5 year warranty they have replaced the bulb each time, which fixes the issue.



SHARE:
+ Post New Thread

Similar Threads

  1. Epson EB-450WI - Screen Surface Suggestions
    By MYK-IT in forum AV and Multimedia Related
    Replies: 8
    Last Post: 24th March 2010, 04:48 PM
  2. Epson EB-460i XGA
    By IanT in forum AV and Multimedia Related
    Replies: 2
    Last Post: 8th March 2010, 07:12 PM
  3. Projector Quotes - Epson EB X6
    By UproarUK in forum Our Advertisers
    Replies: 8
    Last Post: 7th July 2009, 05:51 AM
  4. Replies: 5
    Last Post: 26th April 2008, 12:35 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •