+ Post New Thread
Results 1 to 11 of 11
AV and Multimedia Related Thread, smart UF55 - pixel errors in Technical; I'm thinking not likely, but any fixes for this? corrupt image with dodgy pixels all over the place as in ...
  1. #1

    Join Date
    Sep 2009
    Posts
    140
    Thank Post
    2
    Thanked 9 Times in 8 Posts
    Rep Power
    12

    Unhappy smart UF55 - pixel errors

    I'm thinking not likely, but any fixes for this? corrupt image with dodgy pixels all over the place as in photo attachments.
    Discontinued unit & warranty expired, and limited scope to replace (quickly anyway) due to bespoke boom arm.
    Attached Images Attached Images

  2. #2

    Join Date
    Sep 2013
    Location
    Glasgow
    Posts
    4
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Id look on ebay, normally a couple on there but they are pricy even when they are used.Man, that does look bad. If you get a second unit, you can open that one up & see if there are any loose cables etc.

  3. #3

    Join Date
    Feb 2009
    Location
    Powys
    Posts
    38
    Thank Post
    0
    Thanked 12 Times in 11 Posts
    Rep Power
    14
    Looks like you've got a faulty DMD chip so the only option would be to replace the projector. SMART's UF70 fits on the same fixings at the wall end (the 3 middle ones of the 5 fixings on the UF55) so swappong the boom arm should be fairly straightforward (as long as the UF55 was fitted in the correct position!)

  4. #4

    Join Date
    Sep 2009
    Posts
    140
    Thank Post
    2
    Thanked 9 Times in 8 Posts
    Rep Power
    12
    I've now got a UF55 unit with image that's gone completely black and white - lost all colour. It's not the cables as the usual blue smart logo menu is now grey.
    Would this be the old irreparable chip situation?

  5. #5

    Join Date
    Feb 2009
    Location
    Powys
    Posts
    38
    Thank Post
    0
    Thanked 12 Times in 11 Posts
    Rep Power
    14
    Quote Originally Posted by exim View Post
    I've now got a UF55 unit with image that's gone completely black and white - lost all colour. It's not the cables as the usual blue smart logo menu is now grey.
    Would this be the old irreparable chip situation?
    If everything's gone greyscale with no input it probably isn't the DMD chip. It could be a completely failed and stuck colour wheel, but more likely is that it's a failure on the main driver board. Both are technically repairable but might be costly if the unit's out of warranty.

  6. #6

    Join Date
    Jan 2010
    Location
    St Helens, Merseyside
    Posts
    156
    Thank Post
    3
    Thanked 18 Times in 18 Posts
    Rep Power
    12
    Quote Originally Posted by exim View Post
    I'm thinking not likely, but any fixes for this? corrupt image with dodgy pixels all over the place as in photo attachments.
    Discontinued unit & warranty expired, and limited scope to replace (quickly anyway) due to bespoke boom arm.
    We had one repaired with exactly the same fault a few week's back and it cost around £200 including courier fees.

  7. #7

    Join Date
    Sep 2009
    Posts
    140
    Thank Post
    2
    Thanked 9 Times in 8 Posts
    Rep Power
    12
    who was the service centre please?

  8. #8

    Join Date
    Jan 2010
    Location
    St Helens, Merseyside
    Posts
    156
    Thank Post
    3
    Thanked 18 Times in 18 Posts
    Rep Power
    12
    TSC-UK

    Email address: e.geddes@tsc-europe.com
    Phone: 01923 691865
    Address: 42 Caxton Way
    Watford Business Park Watford,
    Hertforshire WD18 8QZ UK

  9. #9
    Disease's Avatar
    Join Date
    Jan 2006
    Posts
    1,099
    Thank Post
    118
    Thanked 70 Times in 48 Posts
    Rep Power
    56
    We had one of ours repaired there as well, £185 + vat.

    Good service.

  10. #10

    Join Date
    May 2014
    Location
    Canada
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Does anyone considered to change the DMD Chip to repair the UF55?

  11. #11
    Cablers_JonPaul's Avatar
    Join Date
    Apr 2014
    Location
    South East
    Posts
    90
    Thank Post
    7
    Thanked 15 Times in 14 Posts
    Blog Entries
    8
    Rep Power
    39
    Best thing you can do is ring TSC. 01923 691865 service@tsc-europe.com

    They have fixed a few for schools we work with although they do not offer a DE-installation / RE-installation service so you will have to do that yourself or factor it into your costings.

    They can give you pricing for servicing and repairs. Alternatively send me a message and we can sort you out a quote for a replacement unit with an education warranty.

SHARE:
+ Post New Thread

Similar Threads

  1. Looking to replace a Smart UF55
    By speckytecky in forum AV and Multimedia Related
    Replies: 2
    Last Post: 11th September 2013, 10:01 AM
  2. SMART UF55 Bulb Life?
    By speckytecky in forum AV and Multimedia Related
    Replies: 2
    Last Post: 29th January 2013, 09:03 AM
  3. Smart Notebook Installation Error 1613
    By umairadmin in forum Educational Software
    Replies: 0
    Last Post: 14th September 2011, 01:51 PM
  4. SMART Aware and Microsft Office Apps Error
    By Drapec in forum Educational Software
    Replies: 0
    Last Post: 16th June 2010, 11:39 AM
  5. Spollsv.exe smart UI 32 bits gateway error
    By HodgeHi in forum Windows
    Replies: 0
    Last Post: 17th October 2008, 12:58 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •