+ Post New Thread
Results 1 to 9 of 9
AV and Multimedia Related Thread, Benq mx615 Decided to join the xmas spirit! in Technical; Weird one this, I'm putting it down as broke, down one side of the projected image is only what I ...
  1. #1

    Join Date
    May 2010
    Posts
    993
    Thank Post
    98
    Thanked 74 Times in 60 Posts
    Rep Power
    45

    Benq mx615 Decided to join the xmas spirit!

    Weird one this, I'm putting it down as broke, down one side of the projected image is only what I can describe as random "snow" (ok pixels ;p) - Looks quite festive
    I suggested putting a xmas tree down the other side - jokes aside - any ideas?

  2. #2
    north-ict's Avatar
    Join Date
    Sep 2010
    Posts
    703
    Thank Post
    205
    Thanked 140 Times in 105 Posts
    Rep Power
    104
    I have had a couple of BENQ projectors do this its a manufacturer fault is it still under warranty? I had to replace at least three of my newly installed Benq projectors i have on site due to this. It is covered under the warranty. It will gradually get worse.

  3. #3

    Join Date
    May 2010
    Posts
    993
    Thank Post
    98
    Thanked 74 Times in 60 Posts
    Rep Power
    45
    It's 2 years old so not sure, if there's no quick fix it'll have to be replaced - at least I'm not the only one!

  4. #4
    north-ict's Avatar
    Join Date
    Sep 2010
    Posts
    703
    Thank Post
    205
    Thanked 140 Times in 105 Posts
    Rep Power
    104
    Don't they usually come with 3 years? I know mine did. Definitely check up on your warranty for it.

  5. #5

    Oaktech's Avatar
    Join Date
    Jul 2011
    Location
    Bournemouth
    Posts
    2,714
    Thank Post
    752
    Thanked 527 Times in 410 Posts
    Rep Power
    257
    sounds like the DLP chip has gone to me... if its under warranty, call it in, if its not under warranty, throw it.

  6. #6

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    10,991
    Thank Post
    851
    Thanked 2,653 Times in 2,253 Posts
    Blog Entries
    9
    Rep Power
    764
    Check with a different laptop and cable though first to make sure.

  7. #7

    Join Date
    May 2010
    Posts
    993
    Thank Post
    98
    Thanked 74 Times in 60 Posts
    Rep Power
    45
    yep, I checked 3 years it seems, so I got in touch with them - see what pans out.
    cheers everyone.

  8. #8
    north-ict's Avatar
    Join Date
    Sep 2010
    Posts
    703
    Thank Post
    205
    Thanked 140 Times in 105 Posts
    Rep Power
    104
    Quote Originally Posted by caffrey View Post
    yep, I checked 3 years it seems, so I got in touch with them - see what pans out.
    cheers everyone.
    Glad to hear it was still under warranty once its been ok'd they will ask how you want to do the replacement, usually 3 options.

  9. #9

    Join Date
    May 2010
    Posts
    993
    Thank Post
    98
    Thanked 74 Times in 60 Posts
    Rep Power
    45
    Colour me impressed, replacement projector (straight swap out) just landed - big thumbs up to benq

SHARE:
+ Post New Thread

Similar Threads

  1. WDS Unattended - Fails to join the domain
    By Arcolite in forum Windows
    Replies: 0
    Last Post: 7th September 2007, 09:06 AM
  2. Replies: 24
    Last Post: 6th September 2005, 12:26 PM
  3. Parental Consent to use the internet at school
    By mark in forum School ICT Policies
    Replies: 20
    Last Post: 24th June 2005, 11:18 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •