+ Post New Thread
Results 1 to 3 of 3
AV and Multimedia Related Thread, Canon PowerShot A80 won't switch on in Technical; I have an old Powershot A80 and a few years back gave it away to a family friend when I ...
  1. #1

    Dos_Box's Avatar
    Join Date
    Jun 2005
    Location
    Preston, Lancashire
    Posts
    9,427
    Thank Post
    700
    Thanked 2,300 Times in 1,061 Posts
    Blog Entries
    23
    Rep Power
    678

    Canon PowerShot A80 won't switch on

    I have an old Powershot A80 and a few years back gave it away to a family friend when I upgraded to a G10. He returned it a few months back saying it no longer switched on, so we popped in 4xAA (new) and confirmed it. After this I put it in a bottom drawer and forgot about it. Deciding today to give it a look over I see on a couple of forums they mention it has an internal battery (hearing aid sized). Given the age of the camera it is entirely possible that this would now be flat, however I need to know whether it it possible that this could be the cause of it's inability to power up. Is it possible the internal batt could cause this if flat?
    Just so I don't waste half an hour stripping it down to replace it

  2. #2

    GrumbleDook's Avatar
    Join Date
    Jul 2005
    Location
    Gosport, Hampshire
    Posts
    10,074
    Thank Post
    1,384
    Thanked 1,887 Times in 1,169 Posts
    Blog Entries
    19
    Rep Power
    614
    Had similar issues with a Powershot (S series) and the battery was easily accessible so only took a minute to change and it came up a dream. Friend had an A80 with similar and the battery had corroded, so didn't work for her.

  3. #3

    Dos_Box's Avatar
    Join Date
    Jun 2005
    Location
    Preston, Lancashire
    Posts
    9,427
    Thank Post
    700
    Thanked 2,300 Times in 1,061 Posts
    Blog Entries
    23
    Rep Power
    678
    Well, looks like a job for Monday then
    I just hope it isn't corroded and has damaged the circuitry.



SHARE:
+ Post New Thread

Similar Threads

  1. pc won't log on to network
    By IA76 in forum Wireless Networks
    Replies: 5
    Last Post: 20th January 2009, 10:09 AM
  2. Pars and Pars .net won't work on curric domain
    By dezt in forum MIS Systems
    Replies: 5
    Last Post: 5th September 2007, 01:40 PM
  3. Replies: 5
    Last Post: 2nd July 2007, 09:20 AM
  4. Replies: 2
    Last Post: 11th January 2007, 03:39 PM
  5. Windows update won't work on 2000 pro
    By woody in forum Windows
    Replies: 4
    Last Post: 22nd December 2006, 09:59 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •